aboutsummaryrefslogtreecommitdiff
path: root/www/p5-MasonX-Apache2Handler/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-06-11 09:57:22 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-06-11 09:57:22 +0000
commit837891a7142a31a81e0660ea9b7ffc5774fdb27d (patch)
tree1b7667fdcd2423caf947d2def279f1fc74fbd309 /www/p5-MasonX-Apache2Handler/Makefile
parente9f2fe72ad04f329e5b43dfc0a906112da2d9f29 (diff)
downloadports-837891a7142a31a81e0660ea9b7ffc5774fdb27d.tar.gz
ports-837891a7142a31a81e0660ea9b7ffc5774fdb27d.zip
Notes
Diffstat (limited to 'www/p5-MasonX-Apache2Handler/Makefile')
-rw-r--r--www/p5-MasonX-Apache2Handler/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/www/p5-MasonX-Apache2Handler/Makefile b/www/p5-MasonX-Apache2Handler/Makefile
new file mode 100644
index 000000000000..44f2bad52127
--- /dev/null
+++ b/www/p5-MasonX-Apache2Handler/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: www/p5-MasonX-Apache2Handler
+# Date created: June 5, 2004
+# Whom: Autrijus Tang <autrijus@autrijus.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MasonX-Apache2Handler
+PORTVERSION= 0.05
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= MasonX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= autrijus@autrijus.org
+COMMENT= Mason/mod_perl2 interface
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache2:${PORTSDIR}/www/mod_perl2 \
+ ${SITE_PERL}/${PERL_ARCH}/Apache2/Apache/Cookie.pm:${PORTSDIR}/www/p5-libapreq2 \
+ ${SITE_PERL}/HTML/Mason.pm:${PORTSDIR}/www/p5-HTML-Mason
+
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= MasonX::Apache2Handler.3 MasonX::Mason-with-mod_perl2.3
+
+.include <bsd.port.mk>