aboutsummaryrefslogtreecommitdiff
path: root/www/p5-MasonX-WebApp
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2005-02-15 18:17:53 +0000
committerMathieu Arnold <mat@FreeBSD.org>2005-02-15 18:17:53 +0000
commitc3f6706f403a0be4e7b8a5bc2abd6080f695ef9a (patch)
treea64458c28a8fbdec2e709891527b5d7f181a3fdf /www/p5-MasonX-WebApp
parent41a816680b7cdb006336d8a92df331b4570fb099 (diff)
downloadports-c3f6706f403a0be4e7b8a5bc2abd6080f695ef9a.tar.gz
ports-c3f6706f403a0be4e7b8a5bc2abd6080f695ef9a.zip
Notes
Diffstat (limited to 'www/p5-MasonX-WebApp')
-rw-r--r--www/p5-MasonX-WebApp/Makefile42
-rw-r--r--www/p5-MasonX-WebApp/distinfo2
-rw-r--r--www/p5-MasonX-WebApp/pkg-descr24
-rw-r--r--www/p5-MasonX-WebApp/pkg-plist2
4 files changed, 70 insertions, 0 deletions
diff --git a/www/p5-MasonX-WebApp/Makefile b/www/p5-MasonX-WebApp/Makefile
new file mode 100644
index 000000000000..6459a51753bb
--- /dev/null
+++ b/www/p5-MasonX-WebApp/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: p5-MasonX-WebApp
+# Date created: 2005.01.08
+# Whom: Travis Campbell <hcoyote@ghostar.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MasonX-WebApp
+PORTVERSION= 0.08
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= MasonX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hcoyote@ghostar.org
+COMMENT= Works with HTML::Mason to do processing before Mason is invoked
+
+RUN_DEPENDS= ${SITE_PERL}/HTML/Mason.pm:${PORTSDIR}/www/p5-HTML-Mason \
+ ${SITE_PERL}/Apache/Session/Wrapper.pm:${PORTSDIR}/www/p5-Apache-Session-Wrapper \
+ ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ ${SITE_PERL}/Class/Factory/Util.pm:${PORTSDIR}/devel/p5-Class-Factory-Util
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+.if defined(WITH_MODPERL2)
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache2/mod_perl.pm:${PORTSDIR}/www/mod_perl2
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+.endif
+
+PERL_MODBUILD= yes
+
+MAN3= MasonX::WebApp.3
+
+.include <bsd.port.pre.mk>
+
+# Depends on devel/p5-Class-Container whichs needs perl 5.6.x or later
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-MasonX-WebApp/distinfo b/www/p5-MasonX-WebApp/distinfo
new file mode 100644
index 000000000000..a73b2ae58c8f
--- /dev/null
+++ b/www/p5-MasonX-WebApp/distinfo
@@ -0,0 +1,2 @@
+MD5 (MasonX-WebApp-0.08.tar.gz) = ab080390142392ba23a5a4a925a3db75
+SIZE (MasonX-WebApp-0.08.tar.gz) = 18471
diff --git a/www/p5-MasonX-WebApp/pkg-descr b/www/p5-MasonX-WebApp/pkg-descr
new file mode 100644
index 000000000000..bb673dddb1a6
--- /dev/null
+++ b/www/p5-MasonX-WebApp/pkg-descr
@@ -0,0 +1,24 @@
+MasonX::WebApp works with Mason to let you do processing before Mason is ever
+invoked. There are a number of things that one might want to do:
+
+* Argument munging
+
+ You might want to make sure all incoming arguments are UTF-8 encoded.
+ Or you might want to create some objects which Mason will see as
+ incoming arguments. For example, a "user_id" parameter could be turned
+ into a user object.
+
+* Handle requests without Mason
+
+ If you're not generating output for the browser other than a redirect,
+ then there's no reason to use Mason. You can use a MasonX::WebApp
+ subclass to handle all form submissions, for example.
+
+ This has the added benefit of making it easier to preload this code
+ once during server startup.
+
+* And others ...
+
+
+WWW: http://search.cpan.org/dist/MasonX-WebApp/
+WWW: http://www.masonhq.com/?MasonX
diff --git a/www/p5-MasonX-WebApp/pkg-plist b/www/p5-MasonX-WebApp/pkg-plist
new file mode 100644
index 000000000000..87d650705136
--- /dev/null
+++ b/www/p5-MasonX-WebApp/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/MasonX/WebApp.pm
+@unexec rmdir %D/%%SITE_PERL%%/MasonX 2>/dev/null || true