aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Maypole/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2004-05-02 00:03:02 +0000
committerPete Fritchman <petef@FreeBSD.org>2004-05-02 00:03:02 +0000
commit245dcfe4c842e4ce96a04a5d3bfc83f497329fcb (patch)
tree83fe53e5dc21c74a32fcef7b46795d89629383d0 /www/p5-Maypole/Makefile
parent2bad3632511bb7a59421ff1cc51dd020ba60d287 (diff)
downloadports-245dcfe4c842e4ce96a04a5d3bfc83f497329fcb.tar.gz
ports-245dcfe4c842e4ce96a04a5d3bfc83f497329fcb.zip
Notes
Diffstat (limited to 'www/p5-Maypole/Makefile')
-rw-r--r--www/p5-Maypole/Makefile66
1 files changed, 64 insertions, 2 deletions
diff --git a/www/p5-Maypole/Makefile b/www/p5-Maypole/Makefile
index c9dfa039be82..0957d2741d8c 100644
--- a/www/p5-Maypole/Makefile
+++ b/www/p5-Maypole/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= Maypole
-PORTVERSION= 1.3
+PORTVERSION= 1.4
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../by-authors/id/S/SI/SIMON/
@@ -27,16 +27,78 @@ BUILD_DEPENDS= ${SITE_PERL}/Class/DBI/Loader.pm:${PORTSDIR}/databases/p5-Class-D
${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq \
${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+PKGMESSAGE= ${WRKDIR}/pkg-message
+PKGMSG_SUB= DOCSDIR=${DOCSDIR} \
+ DATADIR=${DATADIR} \
+ EXAMPLESDIR=${EXAMPLESDIR}
+
PERL_CONFIGURE= yes
MAN3= Apache::MVC.3 \
+ CGI::Maypole.3 \
Maypole.3 \
+ Maypole::CLI.3 \
Maypole::Model::Base.3 \
Maypole::Model::CDBI.3 \
+ Maypole::View::Mason.3 \
+ Maypole::View::TT.3 \
Maypole::Workflow.3
-.include <bsd.port.pre.mk>
+DOCS= About.pod \
+ Beer.pod \
+ BuySpy.pod \
+ Flox.pod \
+ Model.pod \
+ Overview.pod \
+ Request.pod \
+ StandardTemplates.pod \
+ Templates.pod \
+ View.pod \
+ makedoc.pl
+EXAMPLES= BeerDB.pm
+TMPL_BEER= addnew
+TMPL_CUSTOM= frontpage \
+ header
+TMPL_FACTORY= addnew \
+ edit \
+ header \
+ list \
+ macros \
+ navbar \
+ pager \
+ search_form \
+ view
+
+pre-patch:
+ @ ${SED} ${PKGMSG_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${PKGDIR}/pkg-message > ${PKGMESSAGE}
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${DOCSDIR}
+.for FILE in ${DOCS}
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${DOCSDIR}
+.endfor
+ @ ${MKDIR} ${EXAMPLESDIR}
+.for FILE in ${EXAMPLES}
+ @ ${INSTALL_DATA} ${WRKSRC}/ex/${FILE} ${EXAMPLESDIR}
+.endfor
+.endif
+ @ ${MKDIR} ${DATADIR}/templates/beer
+ @ ${MKDIR} ${DATADIR}/templates/custom
+ @ ${MKDIR} ${DATADIR}/templates/factory
+.for FILE in ${TMPL_BEER}
+ @ ${INSTALL_DATA} ${WRKSRC}/templates/beer/${FILE} ${DATADIR}/templates/beer/
+.endfor
+.for FILE in ${TMPL_CUSTOM}
+ @ ${INSTALL_DATA} ${WRKSRC}/templates/custom/${FILE} ${DATADIR}/templates/custom/
+.endfor
+.for FILE in ${TMPL_FACTORY}
+ @ ${INSTALL_DATA} ${WRKSRC}/templates/factory/${FILE} ${DATADIR}/templates/factory/
+.endfor
+ @ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
IGNORE= "Perl 5.6 or newer required. Install lang/perl5 or lang/perl5.8 and try again."
.endif