aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Maypole
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2004-05-02 00:03:02 +0000
committerPete Fritchman <petef@FreeBSD.org>2004-05-02 00:03:02 +0000
commit245dcfe4c842e4ce96a04a5d3bfc83f497329fcb (patch)
tree83fe53e5dc21c74a32fcef7b46795d89629383d0 /www/p5-Maypole
parent2bad3632511bb7a59421ff1cc51dd020ba60d287 (diff)
downloadports-245dcfe4c842e4ce96a04a5d3bfc83f497329fcb.tar.gz
ports-245dcfe4c842e4ce96a04a5d3bfc83f497329fcb.zip
Notes
Diffstat (limited to 'www/p5-Maypole')
-rw-r--r--www/p5-Maypole/Makefile66
-rw-r--r--www/p5-Maypole/distinfo4
-rw-r--r--www/p5-Maypole/files/patch-Makefile.PL14
-rw-r--r--www/p5-Maypole/pkg-descr8
-rw-r--r--www/p5-Maypole/pkg-message11
-rw-r--r--www/p5-Maypole/pkg-plist42
6 files changed, 125 insertions, 20 deletions
diff --git a/www/p5-Maypole/Makefile b/www/p5-Maypole/Makefile
index c9dfa039be82..0957d2741d8c 100644
--- a/www/p5-Maypole/Makefile
+++ b/www/p5-Maypole/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= Maypole
-PORTVERSION= 1.3
+PORTVERSION= 1.4
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../by-authors/id/S/SI/SIMON/
@@ -27,16 +27,78 @@ BUILD_DEPENDS= ${SITE_PERL}/Class/DBI/Loader.pm:${PORTSDIR}/databases/p5-Class-D
${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq \
${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+PKGMESSAGE= ${WRKDIR}/pkg-message
+PKGMSG_SUB= DOCSDIR=${DOCSDIR} \
+ DATADIR=${DATADIR} \
+ EXAMPLESDIR=${EXAMPLESDIR}
+
PERL_CONFIGURE= yes
MAN3= Apache::MVC.3 \
+ CGI::Maypole.3 \
Maypole.3 \
+ Maypole::CLI.3 \
Maypole::Model::Base.3 \
Maypole::Model::CDBI.3 \
+ Maypole::View::Mason.3 \
+ Maypole::View::TT.3 \
Maypole::Workflow.3
-.include <bsd.port.pre.mk>
+DOCS= About.pod \
+ Beer.pod \
+ BuySpy.pod \
+ Flox.pod \
+ Model.pod \
+ Overview.pod \
+ Request.pod \
+ StandardTemplates.pod \
+ Templates.pod \
+ View.pod \
+ makedoc.pl
+EXAMPLES= BeerDB.pm
+TMPL_BEER= addnew
+TMPL_CUSTOM= frontpage \
+ header
+TMPL_FACTORY= addnew \
+ edit \
+ header \
+ list \
+ macros \
+ navbar \
+ pager \
+ search_form \
+ view
+
+pre-patch:
+ @ ${SED} ${PKGMSG_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${PKGDIR}/pkg-message > ${PKGMESSAGE}
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${DOCSDIR}
+.for FILE in ${DOCS}
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${DOCSDIR}
+.endfor
+ @ ${MKDIR} ${EXAMPLESDIR}
+.for FILE in ${EXAMPLES}
+ @ ${INSTALL_DATA} ${WRKSRC}/ex/${FILE} ${EXAMPLESDIR}
+.endfor
+.endif
+ @ ${MKDIR} ${DATADIR}/templates/beer
+ @ ${MKDIR} ${DATADIR}/templates/custom
+ @ ${MKDIR} ${DATADIR}/templates/factory
+.for FILE in ${TMPL_BEER}
+ @ ${INSTALL_DATA} ${WRKSRC}/templates/beer/${FILE} ${DATADIR}/templates/beer/
+.endfor
+.for FILE in ${TMPL_CUSTOM}
+ @ ${INSTALL_DATA} ${WRKSRC}/templates/custom/${FILE} ${DATADIR}/templates/custom/
+.endfor
+.for FILE in ${TMPL_FACTORY}
+ @ ${INSTALL_DATA} ${WRKSRC}/templates/factory/${FILE} ${DATADIR}/templates/factory/
+.endfor
+ @ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
IGNORE= "Perl 5.6 or newer required. Install lang/perl5 or lang/perl5.8 and try again."
.endif
diff --git a/www/p5-Maypole/distinfo b/www/p5-Maypole/distinfo
index 4866681d14b8..75939c3b6a37 100644
--- a/www/p5-Maypole/distinfo
+++ b/www/p5-Maypole/distinfo
@@ -1,2 +1,2 @@
-MD5 (Maypole-1.3.tar.gz) = 541fb9dd1718c8e92c6edec9b1d9bf64
-SIZE (Maypole-1.3.tar.gz) = 22504
+MD5 (Maypole-1.4.tar.gz) = 36467405c225803624808f5b474be55a
+SIZE (Maypole-1.4.tar.gz) = 66852
diff --git a/www/p5-Maypole/files/patch-Makefile.PL b/www/p5-Maypole/files/patch-Makefile.PL
index 4bdad7ea3015..de2ebbc9b302 100644
--- a/www/p5-Maypole/files/patch-Makefile.PL
+++ b/www/p5-Maypole/files/patch-Makefile.PL
@@ -1,14 +1,6 @@
---- Makefile.PL.orig Thu Mar 25 13:33:42 2004
-+++ Makefile.PL Thu Apr 8 18:13:57 2004
-@@ -20,14 +20,17 @@
- Template => 0,
- }, # e.g., Module::Name => 1.1
- ($] >= 5.005 ? ## Add these new keywords supported since 5.005
-- (ABSTRACT_FROM => 'lib/Apache/MVC.pm', # retrieve abstract from module
-+ (ABSTRACT_FROM => 'lib/Maypole.pm', # retrieve abstract from module
- AUTHOR => 'Simon Cozens <simon@simon-cozens.org>') : ()),
- );
-
+--- Makefile.PL.orig Fri Apr 16 19:16:55 2004
++++ Makefile.PL Sat Apr 17 22:15:01 2004
+@@ -27,7 +27,10 @@
if (!-e "t/beerdb.db") {
print "Making SQLite DB\n";
eval { require DBD::SQLite };
diff --git a/www/p5-Maypole/pkg-descr b/www/p5-Maypole/pkg-descr
index c319da03a1e5..38d6fc794e11 100644
--- a/www/p5-Maypole/pkg-descr
+++ b/www/p5-Maypole/pkg-descr
@@ -1,4 +1,6 @@
-Maypole is an MVC-based web application framework, built around
-Class::DBI and Template Toolkit.
+Maypole is a Perl framework for MVC-oriented web applications,
+similar to Jakarta's Struts. Maypole is designed to minimize coding
+requirements for creating simple web interfaces to databases, while
+remaining flexible enough to support enterprise web applications.
-WWW: http://search.cpan.org/~simon/Maypole/
+WWW: http://search.cpan.org/dist/Maypole/
diff --git a/www/p5-Maypole/pkg-message b/www/p5-Maypole/pkg-message
new file mode 100644
index 000000000000..811ff2c1afdb
--- /dev/null
+++ b/www/p5-Maypole/pkg-message
@@ -0,0 +1,11 @@
+========================================================================
+
+Maypole has now been installed.
+
+Documentation: %%DOCSDIR%%/
+Examples: %%EXAMPLESDIR%%/
+Templates: %%DATADIR%%/templates/
+
+Enjoy!
+
+========================================================================
diff --git a/www/p5-Maypole/pkg-plist b/www/p5-Maypole/pkg-plist
index 90af9b0f2093..eec883c24281 100644
--- a/www/p5-Maypole/pkg-plist
+++ b/www/p5-Maypole/pkg-plist
@@ -1,11 +1,49 @@
%%SITE_PERL%%/Apache/MVC.pm
+%%SITE_PERL%%/CGI/Maypole.pm
%%SITE_PERL%%/Maypole.pm
-%%SITE_PERL%%/Maypole/Workflow.pod
-%%SITE_PERL%%/Maypole/Model/CDBI.pm
+%%SITE_PERL%%/Maypole/CLI.pm
+%%SITE_PERL%%/Maypole/Constants.pm
%%SITE_PERL%%/Maypole/Model/Base.pm
+%%SITE_PERL%%/Maypole/Model/CDBI.pm
+%%SITE_PERL%%/Maypole/View/Base.pm
+%%SITE_PERL%%/Maypole/View/Mason.pm
%%SITE_PERL%%/Maypole/View/TT.pm
+%%SITE_PERL%%/Maypole/Workflow.pod
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Maypole/.packlist
+%%PORTDOCS%%%%DOCSDIR%%/About.pod
+%%PORTDOCS%%%%DOCSDIR%%/Beer.pod
+%%PORTDOCS%%%%DOCSDIR%%/BuySpy.pod
+%%PORTDOCS%%%%DOCSDIR%%/Flox.pod
+%%PORTDOCS%%%%DOCSDIR%%/Model.pod
+%%PORTDOCS%%%%DOCSDIR%%/Overview.pod
+%%PORTDOCS%%%%DOCSDIR%%/Request.pod
+%%PORTDOCS%%%%DOCSDIR%%/StandardTemplates.pod
+%%PORTDOCS%%%%DOCSDIR%%/Templates.pod
+%%PORTDOCS%%%%DOCSDIR%%/View.pod
+%%PORTDOCS%%%%DOCSDIR%%/makedoc.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/BeerDB.pm
+%%DATADIR%%/templates/beer/addnew
+%%DATADIR%%/templates/custom/frontpage
+%%DATADIR%%/templates/custom/header
+%%DATADIR%%/templates/factory/addnew
+%%DATADIR%%/templates/factory/edit
+%%DATADIR%%/templates/factory/header
+%%DATADIR%%/templates/factory/list
+%%DATADIR%%/templates/factory/macros
+%%DATADIR%%/templates/factory/navbar
+%%DATADIR%%/templates/factory/pager
+%%DATADIR%%/templates/factory/search_form
+%%DATADIR%%/templates/factory/view
+@dirrm %%DATADIR%%/templates/factory
+@dirrm %%DATADIR%%/templates/custom
+@dirrm %%DATADIR%%/templates/beer
+@dirrm %%DATADIR%%/templates
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Maypole
@unexec rmdir %D/%%SITE_PERL%%/Maypole/Model 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/Maypole/View 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/Maypole 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/CGI 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Apache 2>/dev/null || true