aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Maypole
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2004-11-21 10:40:43 +0000
committerLars Thegler <lth@FreeBSD.org>2004-11-21 10:40:43 +0000
commit5946cea585175cf01ce66d435093bb6bf4caa149 (patch)
treeaaf9464398119379b64ba779df9ed5c1169758b0 /www/p5-Maypole
parentaed4714254e814a410bc083437b904ac3a75309e (diff)
downloadports-5946cea585175cf01ce66d435093bb6bf4caa149.tar.gz
ports-5946cea585175cf01ce66d435093bb6bf4caa149.zip
Notes
Diffstat (limited to 'www/p5-Maypole')
-rw-r--r--www/p5-Maypole/Makefile65
-rw-r--r--www/p5-Maypole/distinfo4
-rw-r--r--www/p5-Maypole/files/patch-Makefile.PL8
-rw-r--r--www/p5-Maypole/pkg-descr2
-rw-r--r--www/p5-Maypole/pkg-plist28
5 files changed, 73 insertions, 34 deletions
diff --git a/www/p5-Maypole/Makefile b/www/p5-Maypole/Makefile
index f7c29d72e0f8..c8f2274b71fc 100644
--- a/www/p5-Maypole/Makefile
+++ b/www/p5-Maypole/Makefile
@@ -5,11 +5,10 @@
# $FreeBSD$
PORTNAME= Maypole
-PORTVERSION= 1.7
-PORTREVISION= 1
+PORTVERSION= 2.04
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= ../by-authors/id/S/SI/SIMON/
+MASTER_SITE_SUBDIR= ../by-authors/id/S/SR/SRI/
PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
@@ -25,8 +24,28 @@ BUILD_DEPENDS= ${SITE_PERL}/Class/DBI/Loader.pm:${PORTSDIR}/databases/p5-Class-D
${SITE_PERL}/CGI/Untaint.pm:${PORTSDIR}/www/p5-CGI-Untaint \
${SITE_PERL}/UNIVERSAL/moniker.pm:${PORTSDIR}/devel/p5-UNIVERSAL-moniker \
${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-exports \
- ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq \
- ${SITE_PERL}/Template/Plugin/Class.pm:${PORTSDIR}/www/p5-Template-Plugin-Class
+ ${SITE_PERL}/Template/Plugin/Class.pm:${PORTSDIR}/www/p5-Template-Plugin-Class \
+ ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
+ ${SITE_PERL}/Lingua/EN/Inflect/Number.pm:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect-Number \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ ${SITE_PERL}/CGI/Simple.pm:${PORTSDIR}/www/p5-CGI-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+OPTIONS= MODPERL "mod_perl support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MODPERL)
+.if defined(WITH_APACHE2)
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache2/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq2
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache2/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq2
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq
+.endif
+.endif
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGMSG_SUB= DOCSDIR=${DOCSDIR} \
@@ -38,39 +57,51 @@ PERL_CONFIGURE= yes
MAN3= Apache::MVC.3 \
CGI::Maypole.3 \
Maypole.3 \
+ Maypole::Application.3 \
Maypole::CLI.3 \
+ Maypole::Config.3 \
+ Maypole::Constants.3 \
+ Maypole::Manual.3 \
+ Maypole::Manual::About.3 \
+ Maypole::Manual::Beer.3 \
+ Maypole::Manual::BuySpy.3 \
+ Maypole::Manual::Flox.3 \
+ Maypole::Manual::Model.3 \
+ Maypole::Manual::Request.3 \
+ Maypole::Manual::StandardTemplates.3 \
+ Maypole::Manual::View.3 \
+ Maypole::Manual::Workflow.3 \
Maypole::Model::Base.3 \
Maypole::Model::CDBI.3 \
Maypole::Model::CDBI::Plain.3 \
- Maypole::View::Mason.3 \
- Maypole::View::TT.3 \
- Maypole::Workflow.3
+ Maypole::View::Base.3 \
+ Maypole::View::TT.3
-DOC_FILES= About.pod \
+DOC_FILES= ../Manual.pod \
+ About.pod \
Beer.pod \
BuySpy.pod \
Flox.pod \
Model.pod \
- Overview.pod \
Request.pod \
StandardTemplates.pod \
- Templates.pod \
View.pod \
- makedoc.pl
+ Workflow.pod
EXAMPLE_FILES= BeerDB.pm
-TEMPLATE_FILES= beerdb.css \
+TEMPLATE_FILES= maypole.css \
beer/addnew \
- custom/frontpage \
- custom/header \
factory/addnew \
factory/edit \
factory/footer \
+ factory/frontpage \
factory/header \
factory/list \
factory/macros \
+ factory/maypole \
factory/navbar \
factory/pager \
factory/search_form \
+ factory/title \
factory/view
pre-patch:
@@ -81,7 +112,7 @@ post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCSDIR}
.for FILE in ${DOC_FILES}
- @ ${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${DOCSDIR}
+ @ ${INSTALL_DATA} ${WRKSRC}/lib/Maypole/Manual/${FILE} ${DOCSDIR}
.endfor
@ ${MKDIR} ${EXAMPLESDIR}
.for FILE in ${EXAMPLE_FILES}
@@ -89,14 +120,12 @@ post-install:
.endfor
.endif
@ ${MKDIR} ${DATADIR}/templates/beer
- @ ${MKDIR} ${DATADIR}/templates/custom
@ ${MKDIR} ${DATADIR}/templates/factory
.for FILE in ${TEMPLATE_FILES}
@ ${INSTALL_DATA} ${WRKSRC}/templates/${FILE} ${DATADIR}/templates/${FILE}
.endfor
@ ${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
IGNORE= "Perl 5.6 or newer required. Install lang/perl5 or lang/perl5.8 and try again."
.endif
diff --git a/www/p5-Maypole/distinfo b/www/p5-Maypole/distinfo
index bb2b3d5c412f..31a88579ea72 100644
--- a/www/p5-Maypole/distinfo
+++ b/www/p5-Maypole/distinfo
@@ -1,2 +1,2 @@
-MD5 (Maypole-1.7.tar.gz) = a652ec362e46c5eacd901d2adea6d9f8
-SIZE (Maypole-1.7.tar.gz) = 69126
+MD5 (Maypole-2.04.tar.gz) = 85f7ba0825cfbef725dbbbb2025c5b67
+SIZE (Maypole-2.04.tar.gz) = 72772
diff --git a/www/p5-Maypole/files/patch-Makefile.PL b/www/p5-Maypole/files/patch-Makefile.PL
index de2ebbc9b302..ba005208f639 100644
--- a/www/p5-Maypole/files/patch-Makefile.PL
+++ b/www/p5-Maypole/files/patch-Makefile.PL
@@ -1,7 +1,7 @@
---- Makefile.PL.orig Fri Apr 16 19:16:55 2004
-+++ Makefile.PL Sat Apr 17 22:15:01 2004
-@@ -27,7 +27,10 @@
- if (!-e "t/beerdb.db") {
+--- Makefile.PL.orig Mon Nov 8 22:07:59 2004
++++ Makefile.PL Mon Nov 8 22:08:46 2004
+@@ -38,7 +38,10 @@
+ if ( !-e "t/beerdb.db" ) {
print "Making SQLite DB\n";
eval { require DBD::SQLite };
- die "No, wait, we don't have SQLite installed. Never mind\n" if $@;
diff --git a/www/p5-Maypole/pkg-descr b/www/p5-Maypole/pkg-descr
index 38d6fc794e11..2145e4af0515 100644
--- a/www/p5-Maypole/pkg-descr
+++ b/www/p5-Maypole/pkg-descr
@@ -3,4 +3,4 @@ similar to Jakarta's Struts. Maypole is designed to minimize coding
requirements for creating simple web interfaces to databases, while
remaining flexible enough to support enterprise web applications.
-WWW: http://search.cpan.org/dist/Maypole/
+WWW: http://maypole.perl.org/
diff --git a/www/p5-Maypole/pkg-plist b/www/p5-Maypole/pkg-plist
index aa53fdc3ff8d..12e3c0cbe067 100644
--- a/www/p5-Maypole/pkg-plist
+++ b/www/p5-Maypole/pkg-plist
@@ -1,50 +1,60 @@
%%SITE_PERL%%/Apache/MVC.pm
%%SITE_PERL%%/CGI/Maypole.pm
%%SITE_PERL%%/Maypole.pm
+%%SITE_PERL%%/Maypole/Application.pm
%%SITE_PERL%%/Maypole/CLI.pm
+%%SITE_PERL%%/Maypole/Config.pm
%%SITE_PERL%%/Maypole/Constants.pm
+%%SITE_PERL%%/Maypole/Manual.pod
+%%SITE_PERL%%/Maypole/Manual/About.pod
+%%SITE_PERL%%/Maypole/Manual/Beer.pod
+%%SITE_PERL%%/Maypole/Manual/BuySpy.pod
+%%SITE_PERL%%/Maypole/Manual/Flox.pod
+%%SITE_PERL%%/Maypole/Manual/Model.pod
+%%SITE_PERL%%/Maypole/Manual/Request.pod
+%%SITE_PERL%%/Maypole/Manual/StandardTemplates.pod
+%%SITE_PERL%%/Maypole/Manual/View.pod
+%%SITE_PERL%%/Maypole/Manual/Workflow.pod
%%SITE_PERL%%/Maypole/Model/Base.pm
%%SITE_PERL%%/Maypole/Model/CDBI.pm
%%SITE_PERL%%/Maypole/Model/CDBI/Plain.pm
%%SITE_PERL%%/Maypole/View/Base.pm
-%%SITE_PERL%%/Maypole/View/Mason.pm
%%SITE_PERL%%/Maypole/View/TT.pm
-%%SITE_PERL%%/Maypole/Workflow.pod
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Maypole/.packlist
%%PORTDOCS%%%%DOCSDIR%%/About.pod
%%PORTDOCS%%%%DOCSDIR%%/Beer.pod
%%PORTDOCS%%%%DOCSDIR%%/BuySpy.pod
%%PORTDOCS%%%%DOCSDIR%%/Flox.pod
+%%PORTDOCS%%%%DOCSDIR%%/Manual.pod
%%PORTDOCS%%%%DOCSDIR%%/Model.pod
-%%PORTDOCS%%%%DOCSDIR%%/Overview.pod
%%PORTDOCS%%%%DOCSDIR%%/Request.pod
%%PORTDOCS%%%%DOCSDIR%%/StandardTemplates.pod
-%%PORTDOCS%%%%DOCSDIR%%/Templates.pod
%%PORTDOCS%%%%DOCSDIR%%/View.pod
-%%PORTDOCS%%%%DOCSDIR%%/makedoc.pl
+%%PORTDOCS%%%%DOCSDIR%%/Workflow.pod
%%PORTDOCS%%%%EXAMPLESDIR%%/BeerDB.pm
-%%DATADIR%%/templates/beerdb.css
+%%DATADIR%%/templates/maypole.css
%%DATADIR%%/templates/beer/addnew
-%%DATADIR%%/templates/custom/frontpage
-%%DATADIR%%/templates/custom/header
%%DATADIR%%/templates/factory/addnew
%%DATADIR%%/templates/factory/edit
%%DATADIR%%/templates/factory/footer
+%%DATADIR%%/templates/factory/frontpage
%%DATADIR%%/templates/factory/header
%%DATADIR%%/templates/factory/list
%%DATADIR%%/templates/factory/macros
+%%DATADIR%%/templates/factory/maypole
%%DATADIR%%/templates/factory/navbar
%%DATADIR%%/templates/factory/pager
%%DATADIR%%/templates/factory/search_form
+%%DATADIR%%/templates/factory/title
%%DATADIR%%/templates/factory/view
@dirrm %%DATADIR%%/templates/factory
-@dirrm %%DATADIR%%/templates/custom
@dirrm %%DATADIR%%/templates/beer
@dirrm %%DATADIR%%/templates
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Maypole
+@unexec rmdir %D/%%SITE_PERL%%/Maypole/Manual 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/Maypole/Model/CDBI 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/Maypole/Model 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/Maypole/View 2>/dev/null || true