aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Maypole
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-08 20:24:13 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-08 20:24:13 +0000
commit7d808133adf76df012e127ceeba8114e0a2a5e5d (patch)
tree30a6f82a3dce56d2d5fddee90fd87d9b6d085909 /www/p5-Maypole
parent45173ac33fb89a2b3a29b6b04fffe2dd3151bbd0 (diff)
downloadports-7d808133adf76df012e127ceeba8114e0a2a5e5d.tar.gz
ports-7d808133adf76df012e127ceeba8114e0a2a5e5d.zip
Notes
Diffstat (limited to 'www/p5-Maypole')
-rw-r--r--www/p5-Maypole/Makefile38
-rw-r--r--www/p5-Maypole/files/pkg-message.in (renamed from www/p5-Maypole/pkg-message)0
-rw-r--r--www/p5-Maypole/pkg-plist48
3 files changed, 43 insertions, 43 deletions
diff --git a/www/p5-Maypole/Makefile b/www/p5-Maypole/Makefile
index f1052eaaad48..1289ee00065a 100644
--- a/www/p5-Maypole/Makefile
+++ b/www/p5-Maypole/Makefile
@@ -6,6 +6,7 @@
PORTNAME= Maypole
PORTVERSION= 2.13
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../by-authors/id/T/TE/TEEJAY
@@ -14,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= MVC web application framework
-RUN_DEPENDS= p5-CGI-Simple>0:${PORTSDIR}/www/p5-CGI-Simple \
+BUILD_DEPENDS= p5-CGI-Simple>0:${PORTSDIR}/www/p5-CGI-Simple \
p5-CGI-Untaint-date>0:${PORTSDIR}/www/p5-CGI-Untaint-date \
p5-CGI-Untaint-email>0:${PORTSDIR}/www/p5-CGI-Untaint-email \
p5-CGI-Untaint>=1.26:${PORTSDIR}/www/p5-CGI-Untaint \
@@ -36,27 +37,28 @@ RUN_DEPENDS= p5-CGI-Simple>0:${PORTSDIR}/www/p5-CGI-Simple \
p5-UNIVERSAL-require>0:${PORTSDIR}/devel/p5-UNIVERSAL-require \
p5-URI>0:${PORTSDIR}/net/p5-URI \
p5-libwww>0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
-BUILD_DEPENDS= ${RUN_DEPENDS}
-
-OPTIONS= MODPERL "mod_perl support" on
+OPTIONS= MODPERL "mod_perl support" on \
+ MODPERL2 "mod_perl2 support" off
PERL_CONFIGURE= yes
.include <bsd.port.pre.mk>
.if defined(WITH_MODPERL)
-.if defined(WITH_APACHE2)
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache2/Request.pm:${PORTSDIR}/www/p5-libapreq2
-.else
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache2/Request.pm:${PORTSDIR}/www/p5-libapreq2
+.endif
+.if defined(WITH_MODPERL2)
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq
.endif
+
+.if defined(WITH_MODPERL) && defined(WITH_MODPERL2)
+IGNORE= only 1 mod_perl at a time
.endif
PKGMESSAGE= ${WRKDIR}/pkg-message
-PKGMSG_SUB= DOCSDIR=${DOCSDIR} \
- DATADIR=${DATADIR} \
- EXAMPLESDIR=${EXAMPLESDIR}
+SUB_FILES+= pkg-message
MAN3= Apache::MVC.3 \
CGI::Maypole.3 \
@@ -103,18 +105,16 @@ DOC_FILES= ../Manual.pod \
View.pod \
Workflow.pod
-pre-patch:
- @ ${SED} ${PKGMSG_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${PKGDIR}/pkg-message > ${PKGMESSAGE}
-
post-install:
.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${DOCSDIR}
+ @ ${MKDIR} ${DOCSDIR}/
.for FILE in ${DOC_FILES}
- @ ${INSTALL_DATA} ${WRKSRC}/lib/Maypole/Manual/${FILE} ${DOCSDIR}
+ @ ${INSTALL_DATA} ${WRKSRC}/lib/Maypole/Manual/${FILE} ${DOCSDIR}/
.endfor
- @ ${MKDIR} ${EXAMPLESDIR}
- @ ${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @ ${MKDIR} ${EXAMPLESDIR}/
+ @ ${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}/
.endif
@ ${CAT} ${PKGMESSAGE}
diff --git a/www/p5-Maypole/pkg-message b/www/p5-Maypole/files/pkg-message.in
index 7cebb7cf8547..7cebb7cf8547 100644
--- a/www/p5-Maypole/pkg-message
+++ b/www/p5-Maypole/files/pkg-message.in
diff --git a/www/p5-Maypole/pkg-plist b/www/p5-Maypole/pkg-plist
index 13e2be3748c5..1e41b85eff68 100644
--- a/www/p5-Maypole/pkg-plist
+++ b/www/p5-Maypole/pkg-plist
@@ -59,30 +59,30 @@
%%PORTDOCS%%%%DOCSDIR%%/View.pod
%%PORTDOCS%%%%DOCSDIR%%/Workflow.pod
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%%%EXAMPLESDIR%%/BeerDB.pm
-%%PORTDOCS%%%%EXAMPLESDIR%%/BeerDB/Base.pm
-%%PORTDOCS%%%%EXAMPLESDIR%%/BeerDB/Beer.pm
-%%PORTDOCS%%%%EXAMPLESDIR%%/beerdb.sql
-%%PORTDOCS%%%%EXAMPLESDIR%%/fancy_example/BeerDB.pm
-%%PORTDOCS%%%%EXAMPLESDIR%%/fancy_example/BeerDB/Base.pm
-%%PORTDOCS%%%%EXAMPLESDIR%%/fancy_example/BeerDB/Beer.pm
-%%PORTDOCS%%%%EXAMPLESDIR%%/fancy_example/BeerDB/Brewery.pm
-%%PORTDOCS%%%%EXAMPLESDIR%%/fancy_example/BeerDB/Drinker.pm
-%%PORTDOCS%%%%EXAMPLESDIR%%/fancy_example/beerdb.sql
-%%PORTDOCS%%%%EXAMPLESDIR%%/fancy_example/templates/custom/addnew
-%%PORTDOCS%%%%EXAMPLESDIR%%/fancy_example/templates/custom/display_inputs
-%%PORTDOCS%%%%EXAMPLESDIR%%/fancy_example/templates/custom/display_search_inputs
-%%PORTDOCS%%%%EXAMPLESDIR%%/fancy_example/templates/custom/edit
-%%PORTDOCS%%%%EXAMPLESDIR%%/fancy_example/templates/custom/header
-%%PORTDOCS%%%%EXAMPLESDIR%%/fancy_example/templates/custom/maypole.css
-%%PORTDOCS%%%%EXAMPLESDIR%%/fancy_example/templates/custom/metadata
-%%PORTDOCS%%%%EXAMPLESDIR%%/fancy_example/templates/custom/search_form
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/fancy_example/templates/custom
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/fancy_example/templates
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/fancy_example/BeerDB
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/fancy_example
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/BeerDB
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/BeerDB.pm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/BeerDB/Base.pm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/BeerDB/Beer.pm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/beerdb.sql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fancy_example/BeerDB.pm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fancy_example/BeerDB/Base.pm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fancy_example/BeerDB/Beer.pm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fancy_example/BeerDB/Brewery.pm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fancy_example/BeerDB/Drinker.pm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fancy_example/beerdb.sql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fancy_example/templates/custom/addnew
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fancy_example/templates/custom/display_inputs
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fancy_example/templates/custom/display_search_inputs
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fancy_example/templates/custom/edit
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fancy_example/templates/custom/header
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fancy_example/templates/custom/maypole.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fancy_example/templates/custom/metadata
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fancy_example/templates/custom/search_form
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/fancy_example/templates/custom
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/fancy_example/templates
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/fancy_example/BeerDB
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/fancy_example
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/BeerDB
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Maypole
@dirrmtry %%SITE_PERL%%/Maypole/templates/factory
@dirrmtry %%SITE_PERL%%/Maypole/templates/beer