aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Mojo-Server-FastCGI
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2011-11-11 09:32:15 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2011-11-11 09:32:15 +0000
commit42cbd710be146e0d1b964f2e4236c45e9fb8f1f8 (patch)
tree10de413eec86df89fd6b56c32d79e063996e5da8 /www/p5-Mojo-Server-FastCGI
parentb9cc75f6abb1e8887df2938f1456ada8cc4f7a3d (diff)
downloadports-42cbd710be146e0d1b964f2e4236c45e9fb8f1f8.tar.gz
ports-42cbd710be146e0d1b964f2e4236c45e9fb8f1f8.zip
Notes
Diffstat (limited to 'www/p5-Mojo-Server-FastCGI')
-rw-r--r--www/p5-Mojo-Server-FastCGI/Makefile27
-rw-r--r--www/p5-Mojo-Server-FastCGI/distinfo2
-rw-r--r--www/p5-Mojo-Server-FastCGI/pkg-descr3
-rw-r--r--www/p5-Mojo-Server-FastCGI/pkg-plist9
4 files changed, 41 insertions, 0 deletions
diff --git a/www/p5-Mojo-Server-FastCGI/Makefile b/www/p5-Mojo-Server-FastCGI/Makefile
new file mode 100644
index 000000000000..8491a19b97ef
--- /dev/null
+++ b/www/p5-Mojo-Server-FastCGI/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: www/p5-Mojo-Server-FastCGI
+# Date created: 13 Nov 2011
+# Whom: Dikshie <dikshie@sfc.wide.ad.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mojo-Server-FastCGI
+PORTVERSION= 0.2
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:ARPI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dikshie@sfc.wide.ad.jp
+COMMENT= Mojo Server FastCGI
+
+LICENSE= ART20
+
+RUN_DEPENDS= p5-Mojolicious>=0:${PORTSDIR}/www/p5-Mojolicious
+
+PERL_CONFIGURE= yes
+
+MAN3= Mojolicious::Command::fastcgi.3 \
+ Mojo::Server::FastCGI.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Mojo-Server-FastCGI/distinfo b/www/p5-Mojo-Server-FastCGI/distinfo
new file mode 100644
index 000000000000..bd0b14ceeab3
--- /dev/null
+++ b/www/p5-Mojo-Server-FastCGI/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Mojo-Server-FastCGI-0.2.tar.gz) = a1cd0e55af4e6cb9492257931a995b96658ffa9a314c729b92918b24a02294f9
+SIZE (Mojo-Server-FastCGI-0.2.tar.gz) = 10111
diff --git a/www/p5-Mojo-Server-FastCGI/pkg-descr b/www/p5-Mojo-Server-FastCGI/pkg-descr
new file mode 100644
index 000000000000..61098bef0c06
--- /dev/null
+++ b/www/p5-Mojo-Server-FastCGI/pkg-descr
@@ -0,0 +1,3 @@
+Mojo::Server::FastCGI - FastCGI Server
+
+WWW: http://search.cpan.org/dist/Mojo-Server-FastCGI/
diff --git a/www/p5-Mojo-Server-FastCGI/pkg-plist b/www/p5-Mojo-Server-FastCGI/pkg-plist
new file mode 100644
index 000000000000..561a004e93e1
--- /dev/null
+++ b/www/p5-Mojo-Server-FastCGI/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mojo/Server/FastCGI/.packlist
+%%SITE_PERL%%/Mojo/Server/FastCGI.pm
+%%SITE_PERL%%/Mojolicious/Command/fastcgi.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Mojo/Server/FastCGI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Mojo/Server
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Mojo
+@dirrmtry %%SITE_PERL%%/Mojolicious/Command
+@dirrmtry %%SITE_PERL%%/Mojo/Server
+@dirrmtry %%SITE_PERL%%/Mojo