aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Net-Async-FastCGI
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2013-02-18 10:33:31 +0000
committerAnton Berezin <tobez@FreeBSD.org>2013-02-18 10:33:31 +0000
commitfeaa5651be660112f863e48fbfc27cf48c16a006 (patch)
tree81e5ef373cae6218c52c03863f60316312dccae5 /www/p5-Net-Async-FastCGI
parent035f9be2dd543bb9522606532fce702a985b61c2 (diff)
downloadports-feaa5651be660112f863e48fbfc27cf48c16a006.tar.gz
ports-feaa5651be660112f863e48fbfc27cf48c16a006.zip
Notes
Diffstat (limited to 'www/p5-Net-Async-FastCGI')
-rw-r--r--www/p5-Net-Async-FastCGI/Makefile16
-rw-r--r--www/p5-Net-Async-FastCGI/distinfo4
-rw-r--r--www/p5-Net-Async-FastCGI/pkg-plist14
3 files changed, 20 insertions, 14 deletions
diff --git a/www/p5-Net-Async-FastCGI/Makefile b/www/p5-Net-Async-FastCGI/Makefile
index 85794d73a37e..d3f915239ae5 100644
--- a/www/p5-Net-Async-FastCGI/Makefile
+++ b/www/p5-Net-Async-FastCGI/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: p5-Net-Async-FastCGI
-# Date created: 2012-03-31
-# Whom: Steve Wills <swills@FreeBSD.org>
-#
+# Created by: Steve Wills <swills@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Net-Async-FastCGI
-PORTVERSION= 0.24
+PORTVERSION= 0.25
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -22,10 +18,14 @@ BUILD_DEPENDS= p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
p5-Net-FastCGI>=0:${PORTSDIR}/www/p5-Net-FastCGI
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-HexString>=0:${PORTSDIR}/devel/p5-Test-HexString \
- p5-Test-Refcount>0:${PORTSDIR}/devel/p5-Test-Refcount
+ p5-Test-Refcount>0:${PORTSDIR}/devel/p5-Test-Refcount \
+ p5-Test-Identity>=0:${PORTSDIR}/devel/p5-Test-Identity
PERL_CONFIGURE= yes
-MAN3= Net::Async::FastCGI.3 Net::Async::FastCGI::Request.3
+MAN3= Net::Async::FastCGI.3 \
+ Net::Async::FastCGI::PSGI.3 \
+ Net::Async::FastCGI::Request.3 \
+ Plack::Handler::Net::Async::FastCGI.3
.include <bsd.port.mk>
diff --git a/www/p5-Net-Async-FastCGI/distinfo b/www/p5-Net-Async-FastCGI/distinfo
index effe9df81f55..bb363c5ceee3 100644
--- a/www/p5-Net-Async-FastCGI/distinfo
+++ b/www/p5-Net-Async-FastCGI/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Net-Async-FastCGI-0.24.tar.gz) = 8d035a18bdf6f67ecd755c2c7b1b3ae1aa6d76486458b33989618773c689ba91
-SIZE (Net-Async-FastCGI-0.24.tar.gz) = 30883
+SHA256 (Net-Async-FastCGI-0.25.tar.gz) = 478ca5ad8e23c1292867952e1e2e70847477cb5bf4423a11c98c66170ed6182c
+SIZE (Net-Async-FastCGI-0.25.tar.gz) = 36312
diff --git a/www/p5-Net-Async-FastCGI/pkg-plist b/www/p5-Net-Async-FastCGI/pkg-plist
index 80e165ee4180..994ee2fda964 100644
--- a/www/p5-Net-Async-FastCGI/pkg-plist
+++ b/www/p5-Net-Async-FastCGI/pkg-plist
@@ -1,11 +1,17 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Async/FastCGI/.packlist
%%SITE_PERL%%/Net/Async/FastCGI.pm
+%%SITE_PERL%%/Net/Async/FastCGI/PSGI.pm
%%SITE_PERL%%/Net/Async/FastCGI/Protocol.pm
%%SITE_PERL%%/Net/Async/FastCGI/Request.pm
%%SITE_PERL%%/Net/Async/FastCGI/ServerProtocol.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Async/FastCGI/.packlist
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Async/FastCGI
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Async
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+%%SITE_PERL%%/Plack/Handler/Net/Async/FastCGI.pm
+@dirrmtry %%SITE_PERL%%/Plack/Handler/Net/Async
+@dirrmtry %%SITE_PERL%%/Plack/Handler/Net
+@dirrmtry %%SITE_PERL%%/Plack/Handler
+@dirrmtry %%SITE_PERL%%/Plack
@dirrmtry %%SITE_PERL%%/Net/Async/FastCGI
@dirrmtry %%SITE_PERL%%/Net/Async
@dirrmtry %%SITE_PERL%%/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Async/FastCGI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Async
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net