aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Net-FreshBooks-API/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-09-09 19:31:24 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-09-09 19:31:24 +0000
commit3296be6e588d2d73c85619dd5f5d8d99b72d1383 (patch)
tree1df1ac0fe06bdf60b0000f0423412502700bf89b /www/p5-Net-FreshBooks-API/Makefile
parentdfec5abd90970645987edc3bc65e4ed5827976a6 (diff)
downloadports-3296be6e588d2d73c85619dd5f5d8d99b72d1383.tar.gz
ports-3296be6e588d2d73c85619dd5f5d8d99b72d1383.zip
Notes
Diffstat (limited to 'www/p5-Net-FreshBooks-API/Makefile')
-rw-r--r--www/p5-Net-FreshBooks-API/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/www/p5-Net-FreshBooks-API/Makefile b/www/p5-Net-FreshBooks-API/Makefile
index 7f3b5ce8ee58..d43f5f326591 100644
--- a/www/p5-Net-FreshBooks-API/Makefile
+++ b/www/p5-Net-FreshBooks-API/Makefile
@@ -6,20 +6,20 @@
#
PORTNAME= Net-FreshBooks-API
-PORTVERSION= 0.10
+PORTVERSION= 0.12
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= gslin@gslin.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Easy OO access to the FreshBooks.com API
-RUN_DEPENDS= p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
- p5-Clone>0:${PORTSDIR}/devel/p5-Clone \
- p5-Crypt-SSLeay>0:${PORTSDIR}/security/p5-Crypt-SSLeay \
+RUN_DEPENDS= p5-Clone>0:${PORTSDIR}/devel/p5-Clone \
p5-Data-Dump>0:${PORTSDIR}/devel/p5-Data-Dump \
- p5-DateTime>0:${PORTSDIR}/devel/p5-DateTime \
p5-Lingua-EN-Inflect>0:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect \
+ p5-Moose>0:${PORTSDIR}/devel/p5-Moose \
+ p5-Net-OAuth-Simple>0:${PORTSDIR}/net/p5-Net-OAuth-Simple \
+ p5-Params-Validate>0:${PORTSDIR}/devel/p5-Params-Validate \
p5-Path-Class>0:${PORTSDIR}/devel/p5-Path-Class \
p5-URI>0:${PORTSDIR}/net/p5-URI \
p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML \
@@ -30,7 +30,13 @@ PERL_CONFIGURE= yes
MAN3= Net::FreshBooks::API.3 \
Net::FreshBooks::API::Base.3 \
+ Net::FreshBooks::API::Client.3 \
+ Net::FreshBooks::API::Invoice.3 \
+ Net::FreshBooks::API::InvoiceLine.3 \
Net::FreshBooks::API::Iterator.3 \
+ Net::FreshBooks::API::Links.3 \
+ Net::FreshBooks::API::OAuth.3 \
+ Net::FreshBooks::API::Payment.3 \
Net::FreshBooks::API::Recurring.3
.include <bsd.port.mk>