aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Net-STF-Client
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2012-01-02 15:34:19 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2012-01-02 15:34:19 +0000
commitd2373e139b443953fe33170f43fc29796c7ae157 (patch)
treea7efd819444171ae6ba52baafaff3b6df43be37d /www/p5-Net-STF-Client
parentb8213853c66614d5fecff90179bb5346506ad752 (diff)
downloadports-d2373e139b443953fe33170f43fc29796c7ae157.tar.gz
ports-d2373e139b443953fe33170f43fc29796c7ae157.zip
Notes
Diffstat (limited to 'www/p5-Net-STF-Client')
-rw-r--r--www/p5-Net-STF-Client/Makefile30
-rw-r--r--www/p5-Net-STF-Client/distinfo2
-rw-r--r--www/p5-Net-STF-Client/pkg-descr3
-rw-r--r--www/p5-Net-STF-Client/pkg-plist7
4 files changed, 42 insertions, 0 deletions
diff --git a/www/p5-Net-STF-Client/Makefile b/www/p5-Net-STF-Client/Makefile
new file mode 100644
index 000000000000..26a8d1ecfbc1
--- /dev/null
+++ b/www/p5-Net-STF-Client/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Net::STF::Client
+# Date created: 03 Jan 2012
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-STF-Client
+PORTVERSION= 1.00
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for STF Client
+
+RUN_DEPENDS= \
+ p5-Class-Accessor-Lite>0:${PORTSDIR}/devel/p5-Class-Accessor-Lite \
+ p5-Furl>0:${PORTSDIR}/www/p5-Furl \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::STF::Bucket.3 \
+ Net::STF::Client.3 \
+ Net::STF::Object.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Net-STF-Client/distinfo b/www/p5-Net-STF-Client/distinfo
new file mode 100644
index 000000000000..ad0278dbe5e3
--- /dev/null
+++ b/www/p5-Net-STF-Client/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-STF-Client-1.00.tar.gz) = 1717833c84ab047db4dde4a1a32d02d8fcb5d09d31e650c83492e409c46f1b2c
+SIZE (Net-STF-Client-1.00.tar.gz) = 21286
diff --git a/www/p5-Net-STF-Client/pkg-descr b/www/p5-Net-STF-Client/pkg-descr
new file mode 100644
index 000000000000..ca900ef0ee52
--- /dev/null
+++ b/www/p5-Net-STF-Client/pkg-descr
@@ -0,0 +1,3 @@
+Net::STF::Client implements the STF protocol to talk to STF servers.
+
+WWW: http://search.cpan.org/dist/Net-STF-Client/
diff --git a/www/p5-Net-STF-Client/pkg-plist b/www/p5-Net-STF-Client/pkg-plist
new file mode 100644
index 000000000000..a0977c7871fa
--- /dev/null
+++ b/www/p5-Net-STF-Client/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/STF/Client/.packlist
+%%SITE_PERL%%/Net/STF/Bucket.pm
+%%SITE_PERL%%/Net/STF/Client.pm
+%%SITE_PERL%%/Net/STF/Object.pm
+@dirrmtry %%SITE_PERL%%/Net/STF
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/STF/Client
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/STF