aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Nginx-ReadBody
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-05-07 03:01:21 +0000
committerWen Heping <wen@FreeBSD.org>2010-05-07 03:01:21 +0000
commitb1d9d5f16e20cf6164bce5245c06fd6eb154b91e (patch)
tree5a64e6c64d032c39d06c9f7ff208390bf41aa88a /www/p5-Nginx-ReadBody
parentfe288bc865191ca5fabda40e1530d7b8cb54fe6a (diff)
Notes
Diffstat (limited to 'www/p5-Nginx-ReadBody')
-rw-r--r--www/p5-Nginx-ReadBody/Makefile36
-rw-r--r--www/p5-Nginx-ReadBody/distinfo3
-rw-r--r--www/p5-Nginx-ReadBody/pkg-descr4
-rw-r--r--www/p5-Nginx-ReadBody/pkg-message8
-rw-r--r--www/p5-Nginx-ReadBody/pkg-plist7
5 files changed, 58 insertions, 0 deletions
diff --git a/www/p5-Nginx-ReadBody/Makefile b/www/p5-Nginx-ReadBody/Makefile
new file mode 100644
index 000000000000..b71a84ab8a39
--- /dev/null
+++ b/www/p5-Nginx-ReadBody/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Nginx-ReadBody
+# Date created: 2010-04-19
+# Whom: jupengfei <jupengfei@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Nginx-ReadBody
+PORTVERSION= 0.07
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/T/TP/TPABA/Nginx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jupengfei@gmail.com
+COMMENT= Nginx embeded perl module to read and evaluate a request body
+
+OPTIONS= NGINX_DEVEL "Use nginx-devel" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_NGINX_DEVEL)
+RUN_DEPENDS+= nginx:${PORTSDIR}/www/nginx-devel
+.else
+RUN_DEPENDS+= nginx:${PORTSDIR}/www/nginx
+.endif
+
+PERL_CONFIGURE= YES
+
+pre-everything::
+ @${CAT} ${PKGMESSAGE}
+
+MAN3= Nginx::ReadBody.3 \
+ Nginx::ReadBody::Russian.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Nginx-ReadBody/distinfo b/www/p5-Nginx-ReadBody/distinfo
new file mode 100644
index 000000000000..24c4beaf0ff7
--- /dev/null
+++ b/www/p5-Nginx-ReadBody/distinfo
@@ -0,0 +1,3 @@
+MD5 (Nginx-ReadBody-0.07.tar.gz) = a77c1eba6ca7896737285cc4fdf0e9d7
+SHA256 (Nginx-ReadBody-0.07.tar.gz) = 3c2e0afceda83059e2cb2cbf5fcb2908bdb3f17664c62164cf95115a8cec94a6
+SIZE (Nginx-ReadBody-0.07.tar.gz) = 6938
diff --git a/www/p5-Nginx-ReadBody/pkg-descr b/www/p5-Nginx-ReadBody/pkg-descr
new file mode 100644
index 000000000000..bafac45ec67c
--- /dev/null
+++ b/www/p5-Nginx-ReadBody/pkg-descr
@@ -0,0 +1,4 @@
+Nginx::ReadBody is a nginx web server embeded perl module to read
+and evaluate a request body.
+
+WWW: http://search.cpan.org/dist/Nginx-ReadBody/
diff --git a/www/p5-Nginx-ReadBody/pkg-message b/www/p5-Nginx-ReadBody/pkg-message
new file mode 100644
index 000000000000..dd0d9e645c9a
--- /dev/null
+++ b/www/p5-Nginx-ReadBody/pkg-message
@@ -0,0 +1,8 @@
+* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
+
+WARNING:
+ Do not forget compile www/nginx or www/nginx-devel
+ with HTTP_PERL_MODULE support
+
+* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
+
diff --git a/www/p5-Nginx-ReadBody/pkg-plist b/www/p5-Nginx-ReadBody/pkg-plist
new file mode 100644
index 000000000000..87c128af295c
--- /dev/null
+++ b/www/p5-Nginx-ReadBody/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Nginx/ReadBody.pm
+%%SITE_PERL%%/Nginx/ReadBody/Russian.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Nginx/ReadBody/.packlist
+@dirrm %%SITE_PERL%%/Nginx/ReadBody
+@dirrmtry %%SITE_PERL%%/Nginx
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Nginx/ReadBody
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Nginx