aboutsummaryrefslogtreecommitdiff
path: root/www/p5-POEx-Role-PSGIServer
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-10-10 11:04:23 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-10-10 11:04:23 +0000
commit811ad02678f6e1b8e3a24c6740a8f9a7b4ef38ca (patch)
tree4742e988c49b73c0b7d85bb556167515e4938af6 /www/p5-POEx-Role-PSGIServer
parent2f79ea55888a94683f2aad61c8ad5b6af19ae9ad (diff)
downloadports-811ad02678f6e1b8e3a24c6740a8f9a7b4ef38ca.tar.gz
ports-811ad02678f6e1b8e3a24c6740a8f9a7b4ef38ca.zip
Notes
Diffstat (limited to 'www/p5-POEx-Role-PSGIServer')
-rw-r--r--www/p5-POEx-Role-PSGIServer/Makefile41
-rw-r--r--www/p5-POEx-Role-PSGIServer/distinfo3
-rw-r--r--www/p5-POEx-Role-PSGIServer/pkg-descr8
-rw-r--r--www/p5-POEx-Role-PSGIServer/pkg-plist9
4 files changed, 61 insertions, 0 deletions
diff --git a/www/p5-POEx-Role-PSGIServer/Makefile b/www/p5-POEx-Role-PSGIServer/Makefile
new file mode 100644
index 000000000000..aef891ffcbe7
--- /dev/null
+++ b/www/p5-POEx-Role-PSGIServer/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: POEx::Role::PSGIServer
+# Date created: 09 Oct 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POEx-Role-PSGIServer
+PORTVERSION= 1.102531
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/F/FR/FRODWITH
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for encapsulated PSGI server behaviors for POE
+
+RUN_DEPENDS= \
+ p5-Plack>0:${PORTSDIR}/www/p5-Plack \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-Moose-Autobox>0:${PORTSDIR}/devel/p5-Moose-Autobox \
+ p5-MooseX-Declare>0:${PORTSDIR}/devel/p5-MooseX-Declare \
+ p5-MooseX-Types>0:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-MooseX-Types-Structured>0:${PORTSDIR}/devel/p5-MooseX-Types-Structured \
+ p5-POE-Filter-HTTP-Parser>0:${PORTSDIR}/www/p5-POE-Filter-HTTP-Parser \
+ p5-POE>0:${PORTSDIR}/devel/p5-POE \
+ p5-POEx-Role-Streaming>0:${PORTSDIR}/devel/p5-POEx-Role-Streaming \
+ p5-POEx-Role-TCPServer>0:${PORTSDIR}/net/p5-POEx-Role-TCPServer \
+ p5-POEx-Types>0:${PORTSDIR}/devel/p5-POEx-Types \
+ p5-Plack>0:${PORTSDIR}/www/p5-Plack \
+ p5-aliased>0:${PORTSDIR}/devel/p5-aliased
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POEx::Role::PSGIServer.3 \
+ POEx::Role::PSGIServer::ProxyWriter.3 \
+ POEx::Role::PSGIServer::Streamer.3 \
+ POEx::Types::PSGIServer.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-POEx-Role-PSGIServer/distinfo b/www/p5-POEx-Role-PSGIServer/distinfo
new file mode 100644
index 000000000000..d773862d4b4b
--- /dev/null
+++ b/www/p5-POEx-Role-PSGIServer/distinfo
@@ -0,0 +1,3 @@
+MD5 (POEx-Role-PSGIServer-1.102531.tar.gz) = f0a7c03d21f9ef4f3aa4f1fff25f62da
+SHA256 (POEx-Role-PSGIServer-1.102531.tar.gz) = 79533702a04a949537051add8013a4efd1662569ad7023c2517a3151e87c7fb3
+SIZE (POEx-Role-PSGIServer-1.102531.tar.gz) = 15255
diff --git a/www/p5-POEx-Role-PSGIServer/pkg-descr b/www/p5-POEx-Role-PSGIServer/pkg-descr
new file mode 100644
index 000000000000..c79558d178d0
--- /dev/null
+++ b/www/p5-POEx-Role-PSGIServer/pkg-descr
@@ -0,0 +1,8 @@
+POEx::Role::PSGIServer encapsulates the core PSGI server behaviors
+into an easy to consume and extend role. It is based on previous POEx
+work such as POEx::Role::TCPServer which provides basic TCP socket
+multiplexing via POE::Wheel::SocketFactory and POE::Wheel::ReadWrite,
+and POEx::Role::SessionInstantiation which transforms plain Moose
+objects into POE sessions.
+
+WWW: http://search.cpan.org/dist/POEx-Role-PSGIServer/
diff --git a/www/p5-POEx-Role-PSGIServer/pkg-plist b/www/p5-POEx-Role-PSGIServer/pkg-plist
new file mode 100644
index 000000000000..527efae5f239
--- /dev/null
+++ b/www/p5-POEx-Role-PSGIServer/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POEx/Role/PSGIServer/.packlist
+%%SITE_PERL%%/POEx/Role/PSGIServer.pm
+%%SITE_PERL%%/POEx/Role/PSGIServer/ProxyWriter.pm
+%%SITE_PERL%%/POEx/Role/PSGIServer/Streamer.pm
+%%SITE_PERL%%/POEx/Types/PSGIServer.pm
+@dirrmtry %%SITE_PERL%%/POEx/Types
+@dirrmtry %%SITE_PERL%%/POEx/Role/PSGIServer
+@dirrmtry %%SITE_PERL%%/POEx/Role
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POEx/Role/PSGIServer