aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Plack-Handler-CLI
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2011-08-06 09:21:14 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2011-08-06 09:21:14 +0000
commitcc3a761da95e803e94b1dd38c87cd8b79ea91c4f (patch)
treee57e7fe862013af67c1514784197939210aed3c7 /www/p5-Plack-Handler-CLI
parent4526bc6a944b2648dc2a9d8de21a21e6b8af5f0b (diff)
downloadports-cc3a761da95e803e94b1dd38c87cd8b79ea91c4f.tar.gz
ports-cc3a761da95e803e94b1dd38c87cd8b79ea91c4f.zip
Notes
Diffstat (limited to 'www/p5-Plack-Handler-CLI')
-rw-r--r--www/p5-Plack-Handler-CLI/Makefile27
-rw-r--r--www/p5-Plack-Handler-CLI/distinfo2
-rw-r--r--www/p5-Plack-Handler-CLI/pkg-descr4
-rw-r--r--www/p5-Plack-Handler-CLI/pkg-plist4
4 files changed, 37 insertions, 0 deletions
diff --git a/www/p5-Plack-Handler-CLI/Makefile b/www/p5-Plack-Handler-CLI/Makefile
new file mode 100644
index 000000000000..86de42dbc217
--- /dev/null
+++ b/www/p5-Plack-Handler-CLI/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Plack::Handler::CLI
+# Date created: 06 Aug 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Plack-Handler-CLI
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for command line interface to PSGI applications
+
+RUN_DEPENDS= \
+ p5-Any-Moose>0:${PORTSDIR}/devel/p5-Any-Moose \
+ p5-Plack>=0.99:${PORTSDIR}/www/p5-Plack \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Plack::Handler::CLI.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Plack-Handler-CLI/distinfo b/www/p5-Plack-Handler-CLI/distinfo
new file mode 100644
index 000000000000..51c18ffab603
--- /dev/null
+++ b/www/p5-Plack-Handler-CLI/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Plack-Handler-CLI-0.03.tar.gz) = b1fb39d743fb02b3bbb0302290b451db557c8842915d7061423f5eefddb500f6
+SIZE (Plack-Handler-CLI-0.03.tar.gz) = 21449
diff --git a/www/p5-Plack-Handler-CLI/pkg-descr b/www/p5-Plack-Handler-CLI/pkg-descr
new file mode 100644
index 000000000000..e89f2b33b10d
--- /dev/null
+++ b/www/p5-Plack-Handler-CLI/pkg-descr
@@ -0,0 +1,4 @@
+Plack::Handler::CLI is a PSGI handler which provides a command line
+interface for PSGI applications.
+
+WWW: http://search.cpan.org/dist/Plack-Handler-CLI/
diff --git a/www/p5-Plack-Handler-CLI/pkg-plist b/www/p5-Plack-Handler-CLI/pkg-plist
new file mode 100644
index 000000000000..97200fda8cc7
--- /dev/null
+++ b/www/p5-Plack-Handler-CLI/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Handler/CLI/.packlist
+%%SITE_PERL%%/Plack/Handler/CLI.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Handler/CLI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Handler