aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Protocol-XMLRPC
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-23 19:45:40 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-23 19:45:40 +0000
commitcd4f4113839a0f6e04fcea965c430cd966226da2 (patch)
tree431641674bac9fb4a834428b76f887ab5b1a1aee /www/p5-Protocol-XMLRPC
parent290b903a7bcc6c34229665dad05df89df6aca99b (diff)
downloadports-cd4f4113839a0f6e04fcea965c430cd966226da2.tar.gz
ports-cd4f4113839a0f6e04fcea965c430cd966226da2.zip
Notes
Diffstat (limited to 'www/p5-Protocol-XMLRPC')
-rw-r--r--www/p5-Protocol-XMLRPC/Makefile39
-rw-r--r--www/p5-Protocol-XMLRPC/distinfo2
-rw-r--r--www/p5-Protocol-XMLRPC/pkg-descr10
-rw-r--r--www/p5-Protocol-XMLRPC/pkg-plist22
4 files changed, 73 insertions, 0 deletions
diff --git a/www/p5-Protocol-XMLRPC/Makefile b/www/p5-Protocol-XMLRPC/Makefile
new file mode 100644
index 000000000000..688914d15c8f
--- /dev/null
+++ b/www/p5-Protocol-XMLRPC/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-Protocol-XMLRPC
+# Date created: 2011-09-24
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Protocol-XMLRPC
+PORTVERSION= 0.09
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:VTI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= XML-RPC implementation
+
+BUILD_DEPENDS= p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
+RUN_DEPENDS= p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
+
+PERL_CONFIGURE= yes
+
+MAN3= Protocol::XMLRPC.3 \
+ Protocol::XMLRPC::Client.3 \
+ Protocol::XMLRPC::Method.3 \
+ Protocol::XMLRPC::MethodCall.3 \
+ Protocol::XMLRPC::MethodResponse.3 \
+ Protocol::XMLRPC::Value.3 \
+ Protocol::XMLRPC::Value::Array.3 \
+ Protocol::XMLRPC::Value::Base64.3 \
+ Protocol::XMLRPC::Value::Boolean.3 \
+ Protocol::XMLRPC::Value::DateTime.3 \
+ Protocol::XMLRPC::Value::Double.3 \
+ Protocol::XMLRPC::Value::Integer.3 \
+ Protocol::XMLRPC::Value::String.3 \
+ Protocol::XMLRPC::Value::Struct.3 \
+ Protocol::XMLRPC::ValueFactory.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Protocol-XMLRPC/distinfo b/www/p5-Protocol-XMLRPC/distinfo
new file mode 100644
index 000000000000..229d84e992a6
--- /dev/null
+++ b/www/p5-Protocol-XMLRPC/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Protocol-XMLRPC-0.09.tar.gz) = 9b546ff151e892d5404b4d448169c32332e0e2ec4bce20bed0333fe3eef42740
+SIZE (Protocol-XMLRPC-0.09.tar.gz) = 13744
diff --git a/www/p5-Protocol-XMLRPC/pkg-descr b/www/p5-Protocol-XMLRPC/pkg-descr
new file mode 100644
index 000000000000..2fb8b18cf241
--- /dev/null
+++ b/www/p5-Protocol-XMLRPC/pkg-descr
@@ -0,0 +1,10 @@
+Protocol::XMLRPC is an XML-RPC protocol implementation. Method parameters types
+are guessed just like in JSON, but you can pass explicit type if guessing is
+wrong for you. Read more about parameter creation at
+Protocol::XMLRPC::ValueFactory.
+
+It differs from other modules because it doesn't provide any mechanism for
+making actual HTTP requests. This way it can be used either in async or sync
+modes with your favorite http client or a web framework.
+
+WWW: http://search.cpan.org/dist/Protocol-XMLRPC/
diff --git a/www/p5-Protocol-XMLRPC/pkg-plist b/www/p5-Protocol-XMLRPC/pkg-plist
new file mode 100644
index 000000000000..3e14db8721a1
--- /dev/null
+++ b/www/p5-Protocol-XMLRPC/pkg-plist
@@ -0,0 +1,22 @@
+%%SITE_PERL%%/Protocol/XMLRPC.pm
+%%SITE_PERL%%/Protocol/XMLRPC/Client.pm
+%%SITE_PERL%%/Protocol/XMLRPC/Dispatcher.pm
+%%SITE_PERL%%/Protocol/XMLRPC/Method.pm
+%%SITE_PERL%%/Protocol/XMLRPC/MethodCall.pm
+%%SITE_PERL%%/Protocol/XMLRPC/MethodResponse.pm
+%%SITE_PERL%%/Protocol/XMLRPC/Value.pm
+%%SITE_PERL%%/Protocol/XMLRPC/Value/Array.pm
+%%SITE_PERL%%/Protocol/XMLRPC/Value/Base64.pm
+%%SITE_PERL%%/Protocol/XMLRPC/Value/Boolean.pm
+%%SITE_PERL%%/Protocol/XMLRPC/Value/DateTime.pm
+%%SITE_PERL%%/Protocol/XMLRPC/Value/Double.pm
+%%SITE_PERL%%/Protocol/XMLRPC/Value/Integer.pm
+%%SITE_PERL%%/Protocol/XMLRPC/Value/String.pm
+%%SITE_PERL%%/Protocol/XMLRPC/Value/Struct.pm
+%%SITE_PERL%%/Protocol/XMLRPC/ValueFactory.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Protocol/XMLRPC/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Protocol/XMLRPC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Protocol
+@dirrm %%SITE_PERL%%/Protocol/XMLRPC/Value
+@dirrm %%SITE_PERL%%/Protocol/XMLRPC
+@dirrmtry %%SITE_PERL%%/Protocol