aboutsummaryrefslogtreecommitdiff
path: root/www/p5-RT-Authen-ExternalAuth/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2009-01-25 03:51:23 +0000
committerBeech Rintoul <beech@FreeBSD.org>2009-01-25 03:51:23 +0000
commit9ac0428f4ad8be1876e3dc13ce35eed3655df519 (patch)
tree9bae1226ed3d0a1ac13f904d2ef81768458fb273 /www/p5-RT-Authen-ExternalAuth/Makefile
parentd9f621e741a6d45dfef9d94c0195eb5ef6e3b764 (diff)
Notes
Diffstat (limited to 'www/p5-RT-Authen-ExternalAuth/Makefile')
-rw-r--r--www/p5-RT-Authen-ExternalAuth/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/www/p5-RT-Authen-ExternalAuth/Makefile b/www/p5-RT-Authen-ExternalAuth/Makefile
new file mode 100644
index 000000000000..02904c01faf7
--- /dev/null
+++ b/www/p5-RT-Authen-ExternalAuth/Makefile
@@ -0,0 +1,56 @@
+# New ports collection Makefile for: RT-Authen-ExternalAuth
+# Date created: 19 December 2008
+# Whom: Matthew Seaman <m.seaman@infracaninophile.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= RT-Authen-ExternalAuth
+PORTVERSION= 0.05
+CATEGORIES= www net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m.seaman@infracaninophile.co.uk
+COMMENT= RT extension to authenticate users against an external source
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+OPTIONS= RT36 "Install for rt-3.6.x (default rt-3.8.x)" off
+
+PERL_CONFIGURE= yes
+
+MAN3= RT::Authen::ExternalAuth.3 RT::User_Vendor.3
+
+PLIST_SUB+= RTHOME=${RTHOME}
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_RT36)
+
+RTHOME?= rt3
+RT_PM_DIR= ${LOCALBASE}/${RTHOME}/lib
+BUILD_DEPENDS+= ${RT_PM_DIR}/RT.pm:${PORTSDIR}/www/rt36
+PLIST= ${PKGDIR}/pkg-plist.rt36
+MAN3PREFIX= ${PREFIX}/${RTHOME}/local
+
+.else
+
+RTHOME?= share/rt38
+RT_PM_DIR= ${SITE_PERL}
+BUILD_DEPENDS+= ${RT_PM_DIR}/RT.pm:${PORTSDIR}/www/rt38
+PLIST= ${PKGDIR}/pkg-plist.rt38
+MAN3PREFIX= ${PREFIX}
+
+.endif
+
+# Don't use normal CONFIGURE_ARGS. Disable doc_?????_indstall targets to
+# suppress installing perllocal.pod. This duplicates code from bsd.perl.mk
+# rather undesirably.
+do-configure:
+ @cd ${CONFIGURE_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${RT_PM_DIR} ./${CONFIGURE_SCRIPT} && \
+ ${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
+
+.include <bsd.port.post.mk>