aboutsummaryrefslogtreecommitdiff
path: root/www/p5-RT-Extension-LDAPImport
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2013-12-01 17:51:42 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2013-12-01 17:51:42 +0000
commit81f96be9bdebb82e51f8da54e879148f64e88d23 (patch)
tree2cdcc0648640cb2223af863fc4a99233ed50c3a4 /www/p5-RT-Extension-LDAPImport
parent48c1852f77ebb60ad2d9693cdc9bb472333d581d (diff)
downloadports-81f96be9bdebb82e51f8da54e879148f64e88d23.tar.gz
ports-81f96be9bdebb82e51f8da54e879148f64e88d23.zip
Notes
Diffstat (limited to 'www/p5-RT-Extension-LDAPImport')
-rw-r--r--www/p5-RT-Extension-LDAPImport/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/www/p5-RT-Extension-LDAPImport/Makefile b/www/p5-RT-Extension-LDAPImport/Makefile
index aa387e2f3b6f..f7b7eb582523 100644
--- a/www/p5-RT-Extension-LDAPImport/Makefile
+++ b/www/p5-RT-Extension-LDAPImport/Makefile
@@ -3,6 +3,7 @@
PORTNAME= RT-Extension-LDAPImport
PORTVERSION= 0.35
+PORTREVISON= 1
CATEGORIES= www net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -20,16 +21,23 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES+= perl5
USE_PERL5= configure
-OPTIONS_DEFINE= RT38
-RT38_DESC= Install for rt-3.8.x (default rt-4.0.x)
+OPTIONS_SINGLE= RTVERSION
+OPTIONS_SINGLE_RTVERSION= RT38 RT40 RT42
+RT38_DESC= Install for rt-3.8.x (www/rt38)
+RT40_DESC= Install for rt-4.0.x (www/rt40)
+RT42_DESC= Install for rt-4.2.x (www/rt42)
+OPTIONS_DEFAULT= RT42
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MRT38}
-RT_VER= 38
-.else
-RT_VER= 40
+.for opt in 38 40 42
+.if ${PORT_OPTIONS:MRT${opt}}
+RT_VER= ${opt}
.endif
+.endfor
+
+### Temporary for debugging
+#WRKDIR= ${WRKDIRPREFIX}${.CURDIR}/work${RT_VER}
BUILD_DEPENDS+= ${LOCALBASE}/bin/rt:${PORTSDIR}/www/rt${RT_VER}
RUN_DEPENDS+= ${LOCALBASE}/bin/rt:${PORTSDIR}/www/rt${RT_VER}