aboutsummaryrefslogtreecommitdiff
path: root/www/p5-SWF-Chart
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-27 22:11:26 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-27 22:11:26 +0000
commitc84a7923c24a27e6f3fa6f8e51f0611650993880 (patch)
tree305257760309e1d9da91a64db0e8af1ed2760934 /www/p5-SWF-Chart
parent25390dd0bfcd32e9b9920fc0e9cdcdf5d6a03fc2 (diff)
downloadports-c84a7923c24a27e6f3fa6f8e51f0611650993880.tar.gz
ports-c84a7923c24a27e6f3fa6f8e51f0611650993880.zip
Notes
Diffstat (limited to 'www/p5-SWF-Chart')
-rw-r--r--www/p5-SWF-Chart/Makefile30
-rw-r--r--www/p5-SWF-Chart/distinfo2
-rw-r--r--www/p5-SWF-Chart/pkg-descr16
-rw-r--r--www/p5-SWF-Chart/pkg-plist5
4 files changed, 53 insertions, 0 deletions
diff --git a/www/p5-SWF-Chart/Makefile b/www/p5-SWF-Chart/Makefile
new file mode 100644
index 000000000000..f4d14c17b323
--- /dev/null
+++ b/www/p5-SWF-Chart/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-SWF-Chart
+# Date created: 27 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SWF-Chart
+PORTVERSION= 1.3
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/G/GA/GARTH
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Perl interface to the SWF Chart generation tool
+
+MAN3= SWF::Chart.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our (\S+)/use vars qw{$$1};$$1/g' \
+ ${WRKSRC}/lib/SWF/Chart.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-SWF-Chart/distinfo b/www/p5-SWF-Chart/distinfo
new file mode 100644
index 000000000000..2b03f293bb6b
--- /dev/null
+++ b/www/p5-SWF-Chart/distinfo
@@ -0,0 +1,2 @@
+MD5 (SWF-Chart-1.3.tar.gz) = e935d39d3e691f36a32fe12b0121642e
+SIZE (SWF-Chart-1.3.tar.gz) = 6786
diff --git a/www/p5-SWF-Chart/pkg-descr b/www/p5-SWF-Chart/pkg-descr
new file mode 100644
index 000000000000..79cb1a744fc2
--- /dev/null
+++ b/www/p5-SWF-Chart/pkg-descr
@@ -0,0 +1,16 @@
+This module is the Perl interface to the SWF Charts flash graphing tool.
+It constructs the XML file this flash movie requires via an OO interface.
+Each configurable option that is listed on the SWF Charts reference page
+has a companion method in this module.
+
+When using this module, please be sure to use the latest version of the
+XML/SWF Charts flash movie. Earlier versions of that flash movie supported
+a different XML structure for which this module is not backward
+compatible.
+
+Note that there are a few extra helper functions that this module
+provides.
+
+WWW: http://search.cpan.org/dist/SWF-Chart
+ http://www.maani.us/xml_charts/index.php
+Author: Garth Webb <garth@sixapart.com>
diff --git a/www/p5-SWF-Chart/pkg-plist b/www/p5-SWF-Chart/pkg-plist
new file mode 100644
index 000000000000..1421d54abcfb
--- /dev/null
+++ b/www/p5-SWF-Chart/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/SWF/Chart.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SWF/Chart/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SWF/Chart
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SWF
+@dirrmtry %%SITE_PERL%%/SWF