aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Selenium-Remote-Driver
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-01-03 19:01:27 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-01-03 19:01:27 +0000
commitf954a374c99148b8c7d249d77c5ce9acd16f81d0 (patch)
tree446e782dfca5b66487e1ea10819dae0934a88a82 /www/p5-Selenium-Remote-Driver
parent1f5fd2218af0d4fedb0737ba1561d6f6dd32514a (diff)
Notes
Diffstat (limited to 'www/p5-Selenium-Remote-Driver')
-rw-r--r--www/p5-Selenium-Remote-Driver/Makefile31
-rw-r--r--www/p5-Selenium-Remote-Driver/distinfo2
-rw-r--r--www/p5-Selenium-Remote-Driver/pkg-descr7
-rw-r--r--www/p5-Selenium-Remote-Driver/pkg-plist25
4 files changed, 65 insertions, 0 deletions
diff --git a/www/p5-Selenium-Remote-Driver/Makefile b/www/p5-Selenium-Remote-Driver/Makefile
new file mode 100644
index 000000000000..686ea05ca945
--- /dev/null
+++ b/www/p5-Selenium-Remote-Driver/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= Selenium-Remote-Driver
+PORTVERSION= 0.2202
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:GEMPESAW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= Perl Interface for Selenium Remote Driver
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= p5-Archive-Extract>=0.74:${PORTSDIR}/archivers/p5-Archive-Extract \
+ p5-Archive-Zip>=1.39:${PORTSDIR}/archivers/p5-Archive-Zip \
+ p5-HTTP-Message>=6.06:${PORTSDIR}/www/p5-HTTP-Message \
+ p5-JSON>=2.90:${PORTSDIR}/converters/p5-JSON \
+ p5-libwww>=5.829:${PORTSDIR}/www/p5-libwww \
+ p5-Moo>=1:${PORTSDIR}/devel/p5-Moo \
+ p5-Sub-Install>=0.928:${PORTSDIR}/devel/p5-Sub-Install \
+ p5-Test-LongString>=0.17:${PORTSDIR}/devel/p5-Test-LongString \
+ p5-Try-Tiny>=0.18:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-namespace-clean>=0.25:${PORTSDIR}/devel/p5-namespace-clean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/p5-Selenium-Remote-Driver/distinfo b/www/p5-Selenium-Remote-Driver/distinfo
new file mode 100644
index 000000000000..15be09666cd9
--- /dev/null
+++ b/www/p5-Selenium-Remote-Driver/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Selenium-Remote-Driver-0.2202.tar.gz) = 92ba309db02a6bfbcfb751566052142ee10d853083656a37558db7829e336d0f
+SIZE (Selenium-Remote-Driver-0.2202.tar.gz) = 1182686
diff --git a/www/p5-Selenium-Remote-Driver/pkg-descr b/www/p5-Selenium-Remote-Driver/pkg-descr
new file mode 100644
index 000000000000..ac9ccddc5b1a
--- /dev/null
+++ b/www/p5-Selenium-Remote-Driver/pkg-descr
@@ -0,0 +1,7 @@
+Selenium is a test tool that allows you to write automated web
+application UI tests in any programming language against any HTTP
+website using any mainstream JavaScript-enabled browser. This module
+is an implementation of the client for the Remote driver that
+Selenium provides.
+
+WWW: http://search.cpan.org/dist/Selenium-Remote-Driver/
diff --git a/www/p5-Selenium-Remote-Driver/pkg-plist b/www/p5-Selenium-Remote-Driver/pkg-plist
new file mode 100644
index 000000000000..e9b1a5ad5ff2
--- /dev/null
+++ b/www/p5-Selenium-Remote-Driver/pkg-plist
@@ -0,0 +1,25 @@
+%%SITE_PERL%%/Selenium/Remote/Commands.pm
+%%SITE_PERL%%/Selenium/Remote/Driver.pm
+%%SITE_PERL%%/Selenium/Remote/Driver/Firefox/Profile.pm
+%%SITE_PERL%%/Selenium/Remote/ErrorHandler.pm
+%%SITE_PERL%%/Selenium/Remote/Mock/Commands.pm
+%%SITE_PERL%%/Selenium/Remote/Mock/RemoteConnection.pm
+%%SITE_PERL%%/Selenium/Remote/RemoteConnection.pm
+%%SITE_PERL%%/Selenium/Remote/WDKeys.pm
+%%SITE_PERL%%/Selenium/Remote/WebElement.pm
+%%SITE_PERL%%/Selenium/Remote/driver-example.pl
+%%SITE_PERL%%/Test/Selenium/Remote/Driver.pm
+%%SITE_PERL%%/Test/Selenium/Remote/Role/DoesTesting.pm
+%%SITE_PERL%%/Test/Selenium/Remote/WebElement.pm
+%%PERL5_MAN3%%/Selenium::Remote::Commands.3.gz
+%%PERL5_MAN3%%/Selenium::Remote::Driver.3.gz
+%%PERL5_MAN3%%/Selenium::Remote::Driver::Firefox::Profile.3.gz
+%%PERL5_MAN3%%/Selenium::Remote::ErrorHandler.3.gz
+%%PERL5_MAN3%%/Selenium::Remote::Mock::Commands.3.gz
+%%PERL5_MAN3%%/Selenium::Remote::Mock::RemoteConnection.3.gz
+%%PERL5_MAN3%%/Selenium::Remote::RemoteConnection.3.gz
+%%PERL5_MAN3%%/Selenium::Remote::WDKeys.3.gz
+%%PERL5_MAN3%%/Selenium::Remote::WebElement.3.gz
+%%PERL5_MAN3%%/Test::Selenium::Remote::Driver.3.gz
+%%PERL5_MAN3%%/Test::Selenium::Remote::Role::DoesTesting.3.gz
+%%PERL5_MAN3%%/Test::Selenium::Remote::WebElement.3.gz