aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Template-Iterator-AlzaboWrapperCursor
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-08-02 10:54:42 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-08-02 10:54:42 +0000
commit0acc92c3c0e11fd69594af05afa55d4159552811 (patch)
tree065e0275f4a8f6946cdbf3ecf968d5e3c3fc45ea /www/p5-Template-Iterator-AlzaboWrapperCursor
parent6b430b4aed27ac4a372b17043bc63f749693ad3d (diff)
Notes
Diffstat (limited to 'www/p5-Template-Iterator-AlzaboWrapperCursor')
-rw-r--r--www/p5-Template-Iterator-AlzaboWrapperCursor/Makefile25
-rw-r--r--www/p5-Template-Iterator-AlzaboWrapperCursor/distinfo3
-rw-r--r--www/p5-Template-Iterator-AlzaboWrapperCursor/pkg-descr13
-rw-r--r--www/p5-Template-Iterator-AlzaboWrapperCursor/pkg-plist3
4 files changed, 44 insertions, 0 deletions
diff --git a/www/p5-Template-Iterator-AlzaboWrapperCursor/Makefile b/www/p5-Template-Iterator-AlzaboWrapperCursor/Makefile
new file mode 100644
index 000000000000..3078defe786c
--- /dev/null
+++ b/www/p5-Template-Iterator-AlzaboWrapperCursor/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Template-Iterator-AlzaboWrapperCursor
+# Date created: 2 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Iterator-AlzaboWrapperCursor
+DISTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Turns a Class-AlzaboWrapper-Cursor object into a TT2 iterator
+
+BUILD_DEPENDS= p5-Template-Toolkit>=2:${PORTSDIR}/www/p5-Template-Toolkit \
+ p5-Class-AlzaboWrapper>=0:${PORTSDIR}/devel/p5-Class-AlzaboWrapper
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= YES
+
+MAN3= ${PORTNAME:S/-/::/g}.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Template-Iterator-AlzaboWrapperCursor/distinfo b/www/p5-Template-Iterator-AlzaboWrapperCursor/distinfo
new file mode 100644
index 000000000000..f471be4866ba
--- /dev/null
+++ b/www/p5-Template-Iterator-AlzaboWrapperCursor/distinfo
@@ -0,0 +1,3 @@
+MD5 (Template-Iterator-AlzaboWrapperCursor-0.01.tar.gz) = fc522ab4f8f7231c52cc70e78851c9d6
+SHA256 (Template-Iterator-AlzaboWrapperCursor-0.01.tar.gz) = b19afe1137356d9c5e80a831c6d999b3dfe586d0e1252ec23314de76cd2f4843
+SIZE (Template-Iterator-AlzaboWrapperCursor-0.01.tar.gz) = 4356
diff --git a/www/p5-Template-Iterator-AlzaboWrapperCursor/pkg-descr b/www/p5-Template-Iterator-AlzaboWrapperCursor/pkg-descr
new file mode 100644
index 000000000000..5726522ae1ec
--- /dev/null
+++ b/www/p5-Template-Iterator-AlzaboWrapperCursor/pkg-descr
@@ -0,0 +1,13 @@
+This module allows a Class::AlzaboWrapper::Cursor object to be used as
+a TT2 iterator.
+
+For a cursor which returns one object at a time, the iterator simply
+returns one object per iteration. When the cursor returns multiple
+objects, the iterator returns a hash reference where the keys are the
+table name of the object's class in lower-case, with camel-casing
+turned into underscores. The values of the hash are the objects.
+
+So if the cursor returns Foo::User and Foo::Page objects, the keys are
+"user" and "page".
+
+WWW: http://search.cpan.org/dist/Template-Iterator-AlzaboWrapperCursor/
diff --git a/www/p5-Template-Iterator-AlzaboWrapperCursor/pkg-plist b/www/p5-Template-Iterator-AlzaboWrapperCursor/pkg-plist
new file mode 100644
index 000000000000..0d0f97760cc6
--- /dev/null
+++ b/www/p5-Template-Iterator-AlzaboWrapperCursor/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Template/Iterator/AlzaboWrapperCursor.pm
+@dirrmtry %%SITE_PERL%%/Template/Iterator
+@dirrmtry %%SITE_PERL%%/Template