aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Template-Plugin-Clickable
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2006-01-27 11:37:12 +0000
committerLars Thegler <lth@FreeBSD.org>2006-01-27 11:37:12 +0000
commit350c048f9b58abeedc5defb4c068dbb2188c23dd (patch)
treef104d8b70287fccdedc4079e98f5fe8d1fffbddf /www/p5-Template-Plugin-Clickable
parentf42467b02f9b3c530c776a90488c9ff0fc04e2da (diff)
downloadports-350c048f9b58abeedc5defb4c068dbb2188c23dd.tar.gz
ports-350c048f9b58abeedc5defb4c068dbb2188c23dd.zip
Notes
Diffstat (limited to 'www/p5-Template-Plugin-Clickable')
-rw-r--r--www/p5-Template-Plugin-Clickable/Makefile31
-rw-r--r--www/p5-Template-Plugin-Clickable/distinfo3
-rw-r--r--www/p5-Template-Plugin-Clickable/pkg-descr4
-rw-r--r--www/p5-Template-Plugin-Clickable/pkg-plist7
4 files changed, 45 insertions, 0 deletions
diff --git a/www/p5-Template-Plugin-Clickable/Makefile b/www/p5-Template-Plugin-Clickable/Makefile
new file mode 100644
index 000000000000..f2dfd5b9919e
--- /dev/null
+++ b/www/p5-Template-Plugin-Clickable/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: www/p5-Template-Plugin-Clickable
+# Date created: 26 January 2006
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Plugin-Clickable
+PORTVERSION= 0.05
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Template
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= TT plugin to make URLs clickable in HTML
+
+BUILD_DEPENDS= p5-URI-Find>=0.13:${PORTSDIR}/textproc/p5-URI-Find \
+ p5-Template-Toolkit>=2.07:${PORTSDIR}/www/p5-Template-Toolkit \
+ p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Template::Plugin::Clickable.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or newer. Please install lang/perl5 or lang/perl5.6 and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Template-Plugin-Clickable/distinfo b/www/p5-Template-Plugin-Clickable/distinfo
new file mode 100644
index 000000000000..27b320399145
--- /dev/null
+++ b/www/p5-Template-Plugin-Clickable/distinfo
@@ -0,0 +1,3 @@
+MD5 (Template-Plugin-Clickable-0.05.tar.gz) = 27b765945fd6b5b2bcce1b17e5b30919
+SHA256 (Template-Plugin-Clickable-0.05.tar.gz) = ddc120d51f8d27d8151146c1025a39d5e026d3d2fcff4ece22c158e47fa8fa6e
+SIZE (Template-Plugin-Clickable-0.05.tar.gz) = 2778
diff --git a/www/p5-Template-Plugin-Clickable/pkg-descr b/www/p5-Template-Plugin-Clickable/pkg-descr
new file mode 100644
index 000000000000..0d4e76229693
--- /dev/null
+++ b/www/p5-Template-Plugin-Clickable/pkg-descr
@@ -0,0 +1,4 @@
+Template::Plugin::Clickable is a plugin for TT, which allows you
+to filter HTMLs clickable.
+
+WWW: http://search.cpan.org/dist/Template-Plugin-Clickable/
diff --git a/www/p5-Template-Plugin-Clickable/pkg-plist b/www/p5-Template-Plugin-Clickable/pkg-plist
new file mode 100644
index 000000000000..4b190eaa3b92
--- /dev/null
+++ b/www/p5-Template-Plugin-Clickable/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Template/Plugin/Clickable.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Plugin/Clickable/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Plugin/Clickable
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template
+@dirrmtry %%SITE_PERL%%/Template/Plugin
+@dirrmtry %%SITE_PERL%%/Template