aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Template-Plugin-Number-Format
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2006-01-26 22:01:02 +0000
committerLars Thegler <lth@FreeBSD.org>2006-01-26 22:01:02 +0000
commitc86fc0a5a75a6c22aaab498dfb9111e7cea947d6 (patch)
tree48a4cfd4576b190e965643d81c923bac30bd55c6 /www/p5-Template-Plugin-Number-Format
parentbb56d90cb787893bbf63f21b01b7b91058dc064b (diff)
downloadports-c86fc0a5a75a6c22aaab498dfb9111e7cea947d6.tar.gz
ports-c86fc0a5a75a6c22aaab498dfb9111e7cea947d6.zip
Notes
Diffstat (limited to 'www/p5-Template-Plugin-Number-Format')
-rw-r--r--www/p5-Template-Plugin-Number-Format/Makefile30
-rw-r--r--www/p5-Template-Plugin-Number-Format/distinfo3
-rw-r--r--www/p5-Template-Plugin-Number-Format/pkg-descr5
-rw-r--r--www/p5-Template-Plugin-Number-Format/pkg-plist9
4 files changed, 47 insertions, 0 deletions
diff --git a/www/p5-Template-Plugin-Number-Format/Makefile b/www/p5-Template-Plugin-Number-Format/Makefile
new file mode 100644
index 000000000000..cdbbe07b1dda
--- /dev/null
+++ b/www/p5-Template-Plugin-Number-Format/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: www/p5-Template-Plugin-Number-Format
+# Date created: 26 January 2006
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Plugin-Number-Format
+PORTVERSION= 1.01
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Template
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Plugin/filter interface to Number::Format
+
+BUILD_DEPENDS= p5-Number-Format>=0:${PORTSDIR}/textproc/p5-Number-Format \
+ p5-Template-Toolkit>=2.07:${PORTSDIR}/www/p5-Template-Toolkit
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Template::Plugin::Number::Format.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or newer. Please install lang/perl or lang/perl5.8 and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Template-Plugin-Number-Format/distinfo b/www/p5-Template-Plugin-Number-Format/distinfo
new file mode 100644
index 000000000000..a6f030661c0a
--- /dev/null
+++ b/www/p5-Template-Plugin-Number-Format/distinfo
@@ -0,0 +1,3 @@
+MD5 (Template-Plugin-Number-Format-1.01.tar.gz) = 0822bca562c536abc3450cebd66c83f1
+SHA256 (Template-Plugin-Number-Format-1.01.tar.gz) = 41488ba0e93d1cf23349693a8453a52eeec1d4c01dcd2e572a90d7fc67793954
+SIZE (Template-Plugin-Number-Format-1.01.tar.gz) = 3801
diff --git a/www/p5-Template-Plugin-Number-Format/pkg-descr b/www/p5-Template-Plugin-Number-Format/pkg-descr
new file mode 100644
index 000000000000..4ec4c94e6ccf
--- /dev/null
+++ b/www/p5-Template-Plugin-Number-Format/pkg-descr
@@ -0,0 +1,5 @@
+Template::Plugin::Number::Format makes the number-munging grooviness
+of Number::Format available to your templates. It is used like a
+plugin, but installs filters into the current context.
+
+WWW: http://search.cpan.org/dist/Template-Plugin-Number-Format/
diff --git a/www/p5-Template-Plugin-Number-Format/pkg-plist b/www/p5-Template-Plugin-Number-Format/pkg-plist
new file mode 100644
index 000000000000..e531c5c20137
--- /dev/null
+++ b/www/p5-Template-Plugin-Number-Format/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Template/Plugin/Number/Format.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Plugin/Number/Format/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Plugin/Number/Format
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Plugin/Number
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template
+@dirrm %%SITE_PERL%%/Template/Plugin/Number
+@dirrmtry %%SITE_PERL%%/Template/Plugin
+@dirrmtry %%SITE_PERL%%/Template