aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Template-Timer/Makefile
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-05-04 15:12:15 +0000
committerLars Thegler <lth@FreeBSD.org>2005-05-04 15:12:15 +0000
commit9a50223f29e158bb479006ecd78ff5bc50bff1e3 (patch)
tree27327408d417269be1cc31cde14820dc377e985f /www/p5-Template-Timer/Makefile
parentff989b3132eb9cac800115dcd73a29d3d8b17fcf (diff)
downloadports-9a50223f29e158bb479006ecd78ff5bc50bff1e3.tar.gz
ports-9a50223f29e158bb479006ecd78ff5bc50bff1e3.zip
Notes
Diffstat (limited to 'www/p5-Template-Timer/Makefile')
-rw-r--r--www/p5-Template-Timer/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/www/p5-Template-Timer/Makefile b/www/p5-Template-Timer/Makefile
new file mode 100644
index 000000000000..1dac5cdb60a4
--- /dev/null
+++ b/www/p5-Template-Timer/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: www/p5-Template-Timer
+# Date created: 04 May 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Timer
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Template
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Rudimentary profiling for Template Toolkit
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Template::Timer.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Install lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>