aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Test-Nginx
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2013-12-19 04:05:59 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2013-12-19 04:05:59 +0000
commitcd8be1fda8e3e548f7786a59f5154a29d361af88 (patch)
tree970723748fea414d3a5c5419a1cd92aec20dcd23 /www/p5-Test-Nginx
parente8077cff81a5c93da8822501f6f3e4f1fcc4163a (diff)
downloadports-cd8be1fda8e3e548f7786a59f5154a29d361af88.tar.gz
ports-cd8be1fda8e3e548f7786a59f5154a29d361af88.zip
Notes
Diffstat (limited to 'www/p5-Test-Nginx')
-rw-r--r--www/p5-Test-Nginx/Makefile26
-rw-r--r--www/p5-Test-Nginx/distinfo2
-rw-r--r--www/p5-Test-Nginx/pkg-descr3
-rw-r--r--www/p5-Test-Nginx/pkg-plist12
4 files changed, 43 insertions, 0 deletions
diff --git a/www/p5-Test-Nginx/Makefile b/www/p5-Test-Nginx/Makefile
new file mode 100644
index 000000000000..5af0e325712e
--- /dev/null
+++ b/www/p5-Test-Nginx/Makefile
@@ -0,0 +1,26 @@
+# Created by: vanilla@
+# $FreeBSD$
+
+PORTNAME= Test-Nginx
+PORTVERSION= 0.22
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= Testing modules for Nginx C module development
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Test-LongString>=0:${PORTSDIR}/devel/p5-Test-LongString \
+ p5-Test-Base=>0:${PORTSDIR}/devel/p5-Test-Base \
+ p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Text-Diff>=0:${PORTSDIR}/textproc/p5-Text-Diff \
+ p5-libwww>=6:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/www/p5-Test-Nginx/distinfo b/www/p5-Test-Nginx/distinfo
new file mode 100644
index 000000000000..96bc5e54fa14
--- /dev/null
+++ b/www/p5-Test-Nginx/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Test-Nginx-0.22.tar.gz) = cbad54d7d963cd414dce94464c1ade58de0f569b8a82b38d5a880a77bdb3fdca
+SIZE (Test-Nginx-0.22.tar.gz) = 100817
diff --git a/www/p5-Test-Nginx/pkg-descr b/www/p5-Test-Nginx/pkg-descr
new file mode 100644
index 000000000000..e58e82268bb6
--- /dev/null
+++ b/www/p5-Test-Nginx/pkg-descr
@@ -0,0 +1,3 @@
+Testing modules for Nginx C module development
+
+WWW: http://search.cpan.org/dist/Test-Nginx/
diff --git a/www/p5-Test-Nginx/pkg-plist b/www/p5-Test-Nginx/pkg-plist
new file mode 100644
index 000000000000..d6e59fb8fd1d
--- /dev/null
+++ b/www/p5-Test-Nginx/pkg-plist
@@ -0,0 +1,12 @@
+%%PERL5_MAN3%%/Test::Nginx.3.gz
+%%PERL5_MAN3%%/Test::Nginx::LWP.3.gz
+%%PERL5_MAN3%%/Test::Nginx::Socket.3.gz
+%%SITE_PERL%%/Test/Nginx.pm
+%%SITE_PERL%%/Test/Nginx/LWP.pm
+%%SITE_PERL%%/Test/Nginx/Socket.pm
+%%SITE_PERL%%/Test/Nginx/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Nginx/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Nginx
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test/Nginx
+@dirrmtry %%SITE_PERL%%/Test