aboutsummaryrefslogtreecommitdiff
path: root/www/p5-TestGen4Web-Runner/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-06-25 11:04:18 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-06-25 11:04:18 +0000
commit47a9f68b5aa873459f3df17d590b1ca6c5616a40 (patch)
tree3ab4ea8cd56d3b888b309870dcf7e262bfd7e697 /www/p5-TestGen4Web-Runner/Makefile
parent9b86042d4f56d72d1af1ad72583d455748718ccd (diff)
downloadports-47a9f68b5aa873459f3df17d590b1ca6c5616a40.tar.gz
ports-47a9f68b5aa873459f3df17d590b1ca6c5616a40.zip
Notes
Diffstat (limited to 'www/p5-TestGen4Web-Runner/Makefile')
-rw-r--r--www/p5-TestGen4Web-Runner/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/www/p5-TestGen4Web-Runner/Makefile b/www/p5-TestGen4Web-Runner/Makefile
new file mode 100644
index 000000000000..dcc5985b8992
--- /dev/null
+++ b/www/p5-TestGen4Web-Runner/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-TestGen4Web-Runner
+# Date created: June 13th, 2006
+# Whom: Conor McDermottroe <ports@mcdermottroe.com>
+# ex:ts=8
+#
+# $FreeBSD$
+#
+
+PORTNAME= TestGen4Web-Runner
+PORTVERSION= 0.07
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW/MACKERS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@mcdermottroe.com
+COMMENT= A PERL module to replay files recorded with TestGen4Web
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= TestGen4Web::Runner.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or higher. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>