aboutsummaryrefslogtreecommitdiff
path: root/www/p5-URI-Title
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2008-07-02 08:09:46 +0000
committerAnton Berezin <tobez@FreeBSD.org>2008-07-02 08:09:46 +0000
commitcee92c572fc25e6cc4570fc090d086a7e31dbe30 (patch)
tree8eab7c19427fb39855bec07ab12574801f531d30 /www/p5-URI-Title
parenta73a57c4d0168affda36811cc08af737a623c6b5 (diff)
downloadports-cee92c572fc25e6cc4570fc090d086a7e31dbe30.tar.gz
ports-cee92c572fc25e6cc4570fc090d086a7e31dbe30.zip
Notes
Diffstat (limited to 'www/p5-URI-Title')
-rw-r--r--www/p5-URI-Title/Makefile30
-rw-r--r--www/p5-URI-Title/distinfo3
-rw-r--r--www/p5-URI-Title/pkg-descr18
-rw-r--r--www/p5-URI-Title/pkg-plist11
4 files changed, 62 insertions, 0 deletions
diff --git a/www/p5-URI-Title/Makefile b/www/p5-URI-Title/Makefile
new file mode 100644
index 000000000000..013e25ed5ef6
--- /dev/null
+++ b/www/p5-URI-Title/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: www/p5-URI-Title
+# Date created: 20 June 2008
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= URI-Title
+PORTVERSION= 1.80
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= URI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Get the titles of things on the web in a sensible way
+
+BUILD_DEPENDS= p5-Module-Pluggable>=1.2:${PORTSDIR}/devel/p5-Module-Pluggable \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-File-Type>=0.22:${PORTSDIR}/devel/p5-File-Type \
+ p5-HTML-Parser>=3.45:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-Image-Size>0:${PORTSDIR}/graphics/p5-Image-Size \
+ p5-MP3-Info>0:${PORTSDIR}/audio/p5-MP3-Info
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= 5.8.1+
+
+MAN3= URI::Title.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-URI-Title/distinfo b/www/p5-URI-Title/distinfo
new file mode 100644
index 000000000000..b8d910fe7cab
--- /dev/null
+++ b/www/p5-URI-Title/distinfo
@@ -0,0 +1,3 @@
+MD5 (URI-Title-1.80.tar.gz) = 77646327e30bfdcda9594793d96e16ba
+SHA256 (URI-Title-1.80.tar.gz) = 4831e9fb50606f2584310ed7230d7104140014c9a361fcaffec4daa4e72be695
+SIZE (URI-Title-1.80.tar.gz) = 6276
diff --git a/www/p5-URI-Title/pkg-descr b/www/p5-URI-Title/pkg-descr
new file mode 100644
index 000000000000..0d280de4341e
--- /dev/null
+++ b/www/p5-URI-Title/pkg-descr
@@ -0,0 +1,18 @@
+Let's suppose you want to find the title of things on the web. This
+seems like a really simple request, just get() the object, parse for a
+title tag, you're done. There are several problems with this approach:
+
+- What if the resource is on a very slow server? Do we wait for ever or
+ what?
+
+- What if the resource is a 900 gig file? You don't want to download
+ that.
+
+- What if the page title isn't in a title tag, but is buried in the HTML
+ somewhere?
+
+- What if the resource is an MP3 file, or a word document or something?
+
+This module attempts to solve this problem.
+
+WWW: http://search.cpan.org/dist/URI-Title/
diff --git a/www/p5-URI-Title/pkg-plist b/www/p5-URI-Title/pkg-plist
new file mode 100644
index 000000000000..e21f7d017e19
--- /dev/null
+++ b/www/p5-URI-Title/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/URI/Title.pm
+%%SITE_PERL%%/URI/Title/HTML.pm
+%%SITE_PERL%%/URI/Title/Image.pm
+%%SITE_PERL%%/URI/Title/MP3.pm
+%%SITE_PERL%%/URI/Title/PDF.pm
+%%SITE_PERL%%/URI/title.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/URI/Title/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/URI/Title
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/URI
+@dirrmtry %%SITE_PERL%%/URI/Title
+@dirrmtry %%SITE_PERL%%/URI