aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-AtMovies-TV
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-08-31 16:56:53 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-08-31 16:56:53 +0000
commitcc99ba77c55e72fb249983ecf4543aaf659ece3a (patch)
tree5e3300993d37570b0e851667e030cc4618cbb26c /www/p5-WWW-AtMovies-TV
parent338936cee4fc890dac5c0b562385072ec607d1d3 (diff)
downloadports-cc99ba77c55e72fb249983ecf4543aaf659ece3a.tar.gz
ports-cc99ba77c55e72fb249983ecf4543aaf659ece3a.zip
Notes
Diffstat (limited to 'www/p5-WWW-AtMovies-TV')
-rw-r--r--www/p5-WWW-AtMovies-TV/Makefile31
-rw-r--r--www/p5-WWW-AtMovies-TV/distinfo3
-rw-r--r--www/p5-WWW-AtMovies-TV/pkg-descr3
-rw-r--r--www/p5-WWW-AtMovies-TV/pkg-plist7
4 files changed, 44 insertions, 0 deletions
diff --git a/www/p5-WWW-AtMovies-TV/Makefile b/www/p5-WWW-AtMovies-TV/Makefile
new file mode 100644
index 000000000000..3e73ea03057b
--- /dev/null
+++ b/www/p5-WWW-AtMovies-TV/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-WWW-AtMovies-TV
+# Date created: 2008/08/31
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-AtMovies-TV
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Retrieve TV information from http://www.atmovies.com.tw/
+
+BUILD_DEPENDS= p5-HTML-SimpleLinkExtor>=0:${PORTSDIR}/www/p5-HTML-SimpleLinkExtor \
+ p5-HTML-TableExtract>=0:${PORTSDIR}/www/p5-HTML-TableExtract \
+ p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize \
+ p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Moose>=0.25:${PORTSDIR}/devel/p5-Moose \
+ p5-version>=0:${PORTSDIR}/devel/p5-version \
+ p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::AtMovies::TV.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-AtMovies-TV/distinfo b/www/p5-WWW-AtMovies-TV/distinfo
new file mode 100644
index 000000000000..f115fe266a4b
--- /dev/null
+++ b/www/p5-WWW-AtMovies-TV/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-AtMovies-TV-v0.02.tar.gz) = 69ebc326e0c72f384c02deb659c4a874
+SHA256 (WWW-AtMovies-TV-v0.02.tar.gz) = c2e4e9e394ba8b4e98d755cb9cbe98ef9ca3b5718d8f67b65fdd6dcce5050ef9
+SIZE (WWW-AtMovies-TV-v0.02.tar.gz) = 4287
diff --git a/www/p5-WWW-AtMovies-TV/pkg-descr b/www/p5-WWW-AtMovies-TV/pkg-descr
new file mode 100644
index 000000000000..f2be7a6b0b2f
--- /dev/null
+++ b/www/p5-WWW-AtMovies-TV/pkg-descr
@@ -0,0 +1,3 @@
+WWW::AtMovies::TV - retrieve TV information from http://www.atmovies.com.tw/
+
+WWW: http://search.cpan.org/dist/WWW-AtMovies-TV/
diff --git a/www/p5-WWW-AtMovies-TV/pkg-plist b/www/p5-WWW-AtMovies-TV/pkg-plist
new file mode 100644
index 000000000000..5ff50450619d
--- /dev/null
+++ b/www/p5-WWW-AtMovies-TV/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/AtMovies/TV/.packlist
+%%SITE_PERL%%/WWW/AtMovies/TV.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/AtMovies/TV
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/AtMovies
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+@dirrmtry %%SITE_PERL%%/WWW/AtMovies
+@dirrmtry %%SITE_PERL%%/WWW