aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Google-Calculator
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-07-29 09:26:46 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-07-29 09:26:46 +0000
commite381cd625bb85faed2eef94109fb36f6a8e1545c (patch)
treeb6cd05274e886624a48c8b7305a3ac1aadfcfcd8 /www/p5-WWW-Google-Calculator
parent40fc81fd53855d67b8f0b0f932c1d1f6ac6e044b (diff)
downloadports-e381cd625bb85faed2eef94109fb36f6a8e1545c.tar.gz
ports-e381cd625bb85faed2eef94109fb36f6a8e1545c.zip
Notes
Diffstat (limited to 'www/p5-WWW-Google-Calculator')
-rw-r--r--www/p5-WWW-Google-Calculator/Makefile35
-rw-r--r--www/p5-WWW-Google-Calculator/distinfo3
-rw-r--r--www/p5-WWW-Google-Calculator/pkg-descr4
-rw-r--r--www/p5-WWW-Google-Calculator/pkg-plist3
4 files changed, 45 insertions, 0 deletions
diff --git a/www/p5-WWW-Google-Calculator/Makefile b/www/p5-WWW-Google-Calculator/Makefile
new file mode 100644
index 000000000000..d79440b2dec9
--- /dev/null
+++ b/www/p5-WWW-Google-Calculator/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-WWW-Google-Calculator
+# Date created: 2006-07-29
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Google-Calculator
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= This module provide simple interface for Google calculator
+
+BUILD_DEPENDS= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/TokeParser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize \
+ ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= WWW::Google::Calculator.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-Google-Calculator/distinfo b/www/p5-WWW-Google-Calculator/distinfo
new file mode 100644
index 000000000000..2210ea665973
--- /dev/null
+++ b/www/p5-WWW-Google-Calculator/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-Google-Calculator-0.03.tar.gz) = bc99b245a45ff89d6a42ecad14638dbc
+SHA256 (WWW-Google-Calculator-0.03.tar.gz) = 72ac0f7a8b0f106af9d6655ff0b67aceaa56ac2f2c7823bce69799c3c1e9ec78
+SIZE (WWW-Google-Calculator-0.03.tar.gz) = 10262
diff --git a/www/p5-WWW-Google-Calculator/pkg-descr b/www/p5-WWW-Google-Calculator/pkg-descr
new file mode 100644
index 000000000000..ea157e5d92e6
--- /dev/null
+++ b/www/p5-WWW-Google-Calculator/pkg-descr
@@ -0,0 +1,4 @@
+This module provide simple interface for Google calculator.
+
+Author: Daisuke Murase <typester@cpan.org>
+WWW: http://search.cpan.org/dist/WWW-Google-Calculator/
diff --git a/www/p5-WWW-Google-Calculator/pkg-plist b/www/p5-WWW-Google-Calculator/pkg-plist
new file mode 100644
index 000000000000..cab5ce2a1e32
--- /dev/null
+++ b/www/p5-WWW-Google-Calculator/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/WWW/Google/Calculator.pm
+@dirrmtry %%SITE_PERL%%/WWW/Google
+@dirrmtry %%SITE_PERL%%/WWW