aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Google-News/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-07-18 16:12:07 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-07-18 16:12:07 +0000
commit48351d7d0d9240786301686556f19ffa34d5ef98 (patch)
tree80ae2493c87b1f1a1424d57f29884fffa5bc0741 /www/p5-WWW-Google-News/Makefile
parent0d74111b6e871cc205471319218aae712452444e (diff)
downloadports-48351d7d0d9240786301686556f19ffa34d5ef98.tar.gz
ports-48351d7d0d9240786301686556f19ffa34d5ef98.zip
Notes
Diffstat (limited to 'www/p5-WWW-Google-News/Makefile')
-rw-r--r--www/p5-WWW-Google-News/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/www/p5-WWW-Google-News/Makefile b/www/p5-WWW-Google-News/Makefile
new file mode 100644
index 000000000000..530705058ec1
--- /dev/null
+++ b/www/p5-WWW-Google-News/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-WWW-Google-News
+# Date created: 2006-07-17
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Google-News
+PORTVERSION= 0.11
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= Access to Google's News Service (Not Usenet)
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Google::News.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+SASL
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>