aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Google-Notebook/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-11-01 01:10:37 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-11-01 01:10:37 +0000
commitcf429403cc9dc86f947147585a1e09f6338e689e (patch)
treef25e423beaab3b391e0271d41a823322aaa6694e /www/p5-WWW-Google-Notebook/Makefile
parent5f2b26963c74f3ee2b94fefd4a0d79e755ddd10a (diff)
downloadports-cf429403cc9dc86f947147585a1e09f6338e689e.tar.gz
ports-cf429403cc9dc86f947147585a1e09f6338e689e.zip
Notes
Diffstat (limited to 'www/p5-WWW-Google-Notebook/Makefile')
-rw-r--r--www/p5-WWW-Google-Notebook/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/www/p5-WWW-Google-Notebook/Makefile b/www/p5-WWW-Google-Notebook/Makefile
new file mode 100644
index 000000000000..5d37eb1dc1bf
--- /dev/null
+++ b/www/p5-WWW-Google-Notebook/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-WWW-Google-Notebook
+# Date created: 2006-10-15
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Google-Notebook
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= Perl interface for Google Notebook
+
+RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Google::Notebook.3 WWW::Google::Notebook::Note.3 WWW::Google::Notebook::Notebook.3
+
+.include <bsd.port.mk>