aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Google-Video
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-21 14:18:45 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-21 14:18:45 +0000
commitc017b4ac8a31f835da77d353fa8488dc8058b14b (patch)
treea0cf7b13d6613d767e3c18a9fce4baac104ee09f /www/p5-WWW-Google-Video
parent3705fac30af33c1cff970a41296e223fdb226bc0 (diff)
downloadports-c017b4ac8a31f835da77d353fa8488dc8058b14b.tar.gz
ports-c017b4ac8a31f835da77d353fa8488dc8058b14b.zip
Notes
Diffstat (limited to 'www/p5-WWW-Google-Video')
-rw-r--r--www/p5-WWW-Google-Video/Makefile31
-rw-r--r--www/p5-WWW-Google-Video/distinfo3
-rw-r--r--www/p5-WWW-Google-Video/pkg-descr8
-rw-r--r--www/p5-WWW-Google-Video/pkg-plist7
4 files changed, 49 insertions, 0 deletions
diff --git a/www/p5-WWW-Google-Video/Makefile b/www/p5-WWW-Google-Video/Makefile
new file mode 100644
index 000000000000..076e479506f4
--- /dev/null
+++ b/www/p5-WWW-Google-Video/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-WWW-Google-Video
+# Date created: 2006-07-19
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Google-Video
+PORTVERSION= 0.3
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW/KENWU
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= This's a interface for fetch the Google Video Information
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Google::Video.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-Google-Video/distinfo b/www/p5-WWW-Google-Video/distinfo
new file mode 100644
index 000000000000..29c42699df24
--- /dev/null
+++ b/www/p5-WWW-Google-Video/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-Google-Video-0.3.tar.gz) = 46fe988f621fb90fe7de6cf16cd1e5f0
+SHA256 (WWW-Google-Video-0.3.tar.gz) = b94d1b818f03ee3bf23a761dbd50aadfd94caeb347c0bb27fe15aa418914e62a
+SIZE (WWW-Google-Video-0.3.tar.gz) = 7949
diff --git a/www/p5-WWW-Google-Video/pkg-descr b/www/p5-WWW-Google-Video/pkg-descr
new file mode 100644
index 000000000000..b3a6749a1966
--- /dev/null
+++ b/www/p5-WWW-Google-Video/pkg-descr
@@ -0,0 +1,8 @@
+The WWW::Google::Video is a class implementing a interface
+for fetch the Google Video Information.
+To use it, you should create WWW::Google::Video object
+and use its method fetch(), to fetch the information of Video.
+It uses LWP::Simple for making request to Google.
+
+Author: Lilo Huang <kenwu@mail.tnssh.tn.edu.tw>
+WWW: http://search.cpan.org/~kenwu/WWW-Google-Video/
diff --git a/www/p5-WWW-Google-Video/pkg-plist b/www/p5-WWW-Google-Video/pkg-plist
new file mode 100644
index 000000000000..a946db4ebf1b
--- /dev/null
+++ b/www/p5-WWW-Google-Video/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/WWW/Google/Video.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Google/Video/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Google/Video
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Google
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+@dirrmtry %%SITE_PERL%%/WWW/Google
+@dirrmtry %%SITE_PERL%%/WWW