aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Instapaper-Client
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-01-07 02:11:46 +0000
committerWen Heping <wen@FreeBSD.org>2011-01-07 02:11:46 +0000
commit1cbf260f24a906288d004514dedaea25ad0f69ef (patch)
tree571dc726e4d1ca13086c05bd3036dccfd8a96f10 /www/p5-WWW-Instapaper-Client
parent0eed1f29217e197bacfd762a03265b40906ccd14 (diff)
downloadports-1cbf260f24a906288d004514dedaea25ad0f69ef.tar.gz
ports-1cbf260f24a906288d004514dedaea25ad0f69ef.zip
Notes
Diffstat (limited to 'www/p5-WWW-Instapaper-Client')
-rw-r--r--www/p5-WWW-Instapaper-Client/Makefile26
-rw-r--r--www/p5-WWW-Instapaper-Client/distinfo2
-rw-r--r--www/p5-WWW-Instapaper-Client/pkg-descr4
-rw-r--r--www/p5-WWW-Instapaper-Client/pkg-plist6
4 files changed, 38 insertions, 0 deletions
diff --git a/www/p5-WWW-Instapaper-Client/Makefile b/www/p5-WWW-Instapaper-Client/Makefile
new file mode 100644
index 000000000000..17ff75dd7476
--- /dev/null
+++ b/www/p5-WWW-Instapaper-Client/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-WWW-Instapaper-Client
+# Date created: 2011-01-05
+# Whom: TERAMOTO Masahiro <markun@onohara.to>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Instapaper-Client
+PORTVERSION= 0.901
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= markun@onohara.to
+COMMENT= An implementation of the Instapaper client API
+
+BUILD_DEPENDS= p5-Class-Base>=0:${PORTSDIR}/devel/p5-Class-Base \
+ p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= WWW::Instapaper::Client.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Instapaper-Client/distinfo b/www/p5-WWW-Instapaper-Client/distinfo
new file mode 100644
index 000000000000..8fd58a0c8673
--- /dev/null
+++ b/www/p5-WWW-Instapaper-Client/distinfo
@@ -0,0 +1,2 @@
+SHA256 (WWW-Instapaper-Client-0.901.tar.gz) = 6b984b34366fb38a7f537b5947767fbcd1fae6f68e0591ae1e6802f10227fa2d
+SIZE (WWW-Instapaper-Client-0.901.tar.gz) = 3936
diff --git a/www/p5-WWW-Instapaper-Client/pkg-descr b/www/p5-WWW-Instapaper-Client/pkg-descr
new file mode 100644
index 000000000000..167c08d006a2
--- /dev/null
+++ b/www/p5-WWW-Instapaper-Client/pkg-descr
@@ -0,0 +1,4 @@
+An implementation of the Instapaper client API.
+(see http://www.instapaper.com/api)
+
+WWW: http://search.cpan.org/dist/WWW-Instapaper-Client/
diff --git a/www/p5-WWW-Instapaper-Client/pkg-plist b/www/p5-WWW-Instapaper-Client/pkg-plist
new file mode 100644
index 000000000000..ffc568902cd0
--- /dev/null
+++ b/www/p5-WWW-Instapaper-Client/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/WWW/Instapaper/Client.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Instapaper
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+@dirrmtry %%SITE_PERL%%/WWW/Instapaper
+@dirrmtry %%SITE_PERL%%/WWW