aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Mechanize-GZip
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2009-04-22 02:53:16 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2009-04-22 02:53:16 +0000
commita0f6c3e7de8b9a7e006977e88f4cf796db1aed7f (patch)
treeabc42f79f9994a02fb9a694d0a5b8f9a988b8696 /www/p5-WWW-Mechanize-GZip
parentb0c9b9e6656f5e4733432bb2c315d0d7429a263e (diff)
downloadports-a0f6c3e7de8b9a7e006977e88f4cf796db1aed7f.tar.gz
ports-a0f6c3e7de8b9a7e006977e88f4cf796db1aed7f.zip
Notes
Diffstat (limited to 'www/p5-WWW-Mechanize-GZip')
-rw-r--r--www/p5-WWW-Mechanize-GZip/Makefile25
-rw-r--r--www/p5-WWW-Mechanize-GZip/distinfo3
-rw-r--r--www/p5-WWW-Mechanize-GZip/pkg-descr15
-rw-r--r--www/p5-WWW-Mechanize-GZip/pkg-plist7
4 files changed, 50 insertions, 0 deletions
diff --git a/www/p5-WWW-Mechanize-GZip/Makefile b/www/p5-WWW-Mechanize-GZip/Makefile
new file mode 100644
index 000000000000..b04e102c35f4
--- /dev/null
+++ b/www/p5-WWW-Mechanize-GZip/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-WWW-Mechanize-GZip
+# Date created: 21 Apr 2009
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Mechanize-GZip
+PORTVERSION= 0.10
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Use WWW::Mechanize by requesting gzip-compression from the webserver
+
+RUN_DEPENDS= ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Mechanize::GZip.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Mechanize-GZip/distinfo b/www/p5-WWW-Mechanize-GZip/distinfo
new file mode 100644
index 000000000000..a4d989a8172e
--- /dev/null
+++ b/www/p5-WWW-Mechanize-GZip/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-Mechanize-GZip-0.10.tar.gz) = 3330179ed9d3e637694b4f5632b6aef5
+SHA256 (WWW-Mechanize-GZip-0.10.tar.gz) = 141edac0d81b5418aedd2baa4220b75f935f99573a50aa364c7fb52b07845007
+SIZE (WWW-Mechanize-GZip-0.10.tar.gz) = 2908
diff --git a/www/p5-WWW-Mechanize-GZip/pkg-descr b/www/p5-WWW-Mechanize-GZip/pkg-descr
new file mode 100644
index 000000000000..cb1466849250
--- /dev/null
+++ b/www/p5-WWW-Mechanize-GZip/pkg-descr
@@ -0,0 +1,15 @@
+The WWW::Mechanize::GZip module tries to fetch a URL by requesting
+gzip-compression from the webserver.
+
+If the response contains a header with 'Content-Encoding: gzip',
+it decompresses the response in order to get the original
+(uncompressed) content.
+
+This module will help to reduce bandwith fetching webpages, if
+supported by the webeserver. If the webserver does not support
+gzip-compression, no decompression will be made.
+
+This modules is a direct subclass of WWW::Mechanize and will
+therefore support any methods provided by WWW::Mechanize.
+
+WWW: http://search.cpan.org/dist/WWW-Mechanize-Gzip/
diff --git a/www/p5-WWW-Mechanize-GZip/pkg-plist b/www/p5-WWW-Mechanize-GZip/pkg-plist
new file mode 100644
index 000000000000..4352146a89a8
--- /dev/null
+++ b/www/p5-WWW-Mechanize-GZip/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/WWW/Mechanize/GZip.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Mechanize/GZip/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Mechanize/GZip
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Mechanize
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+@dirrmtry %%SITE_PERL%%/WWW/Mechanize
+@dirrmtry %%SITE_PERL%%/WWW