aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Mechanize-PhantomJS
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-01-03 20:31:52 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-01-03 20:31:52 +0000
commit2a70ba2ace588daa9e2e93b137afaa51456695f2 (patch)
tree6331848d6f3198be92698fb08be04fe815db35c3 /www/p5-WWW-Mechanize-PhantomJS
parent05d71c79466326e51ebe8665cf240a2943844e13 (diff)
downloadports-2a70ba2ace588daa9e2e93b137afaa51456695f2.tar.gz
ports-2a70ba2ace588daa9e2e93b137afaa51456695f2.zip
Notes
Diffstat (limited to 'www/p5-WWW-Mechanize-PhantomJS')
-rw-r--r--www/p5-WWW-Mechanize-PhantomJS/Makefile26
-rw-r--r--www/p5-WWW-Mechanize-PhantomJS/distinfo2
-rw-r--r--www/p5-WWW-Mechanize-PhantomJS/pkg-descr5
-rw-r--r--www/p5-WWW-Mechanize-PhantomJS/pkg-plist75
4 files changed, 108 insertions, 0 deletions
diff --git a/www/p5-WWW-Mechanize-PhantomJS/Makefile b/www/p5-WWW-Mechanize-PhantomJS/Makefile
new file mode 100644
index 000000000000..06646323d4e9
--- /dev/null
+++ b/www/p5-WWW-Mechanize-PhantomJS/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= WWW-Mechanize-PhantomJS
+PORTVERSION= 0.11
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= Automate interaction with javascript websites
+
+LICENSE= ARTPERL10
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/phantomjs:${PORTSDIR}/lang/phantomjs \
+ p5-WWW-Mechanize>=1.73:${PORTSDIR}/www/p5-WWW-Mechanize \
+ p5-Object-Import>=1.004:${PORTSDIR}/devel/p5-Object-Import \
+ p5-Selenium-Remote-Driver>=0.2202:${PORTSDIR}/www/p5-Selenium-Remote-Driver \
+ p5-HTML-Selector-XPath>=0.14:${PORTSDIR}/www/p5-HTML-Selector-XPath
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-HTTP-Daemon>=6.0:${PORTSDIR}/www/p5-HTTP-Daemon \
+ p5-libwww>=5.829:${PORTSDIR}/www/p5-libwww
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Mechanize-PhantomJS/distinfo b/www/p5-WWW-Mechanize-PhantomJS/distinfo
new file mode 100644
index 000000000000..f963c8f19dc4
--- /dev/null
+++ b/www/p5-WWW-Mechanize-PhantomJS/distinfo
@@ -0,0 +1,2 @@
+SHA256 (WWW-Mechanize-PhantomJS-0.11.tar.gz) = 392b106dac175632a86ed71b9d70446147617e5a5cd76d83777794854bafc1a4
+SIZE (WWW-Mechanize-PhantomJS-0.11.tar.gz) = 610429
diff --git a/www/p5-WWW-Mechanize-PhantomJS/pkg-descr b/www/p5-WWW-Mechanize-PhantomJS/pkg-descr
new file mode 100644
index 000000000000..5ae2d267b118
--- /dev/null
+++ b/www/p5-WWW-Mechanize-PhantomJS/pkg-descr
@@ -0,0 +1,5 @@
+WWW::Mechanize::PhantomJS automates the headless webbrowser PhantomJS
+and handles DOM handling, CSS selector, JSON, Canvas, SVG, and of
+course JavaScript.
+
+WWW: http://search.cpan.org/dist/WWW-Mechanize-PhantomJS/
diff --git a/www/p5-WWW-Mechanize-PhantomJS/pkg-plist b/www/p5-WWW-Mechanize-PhantomJS/pkg-plist
new file mode 100644
index 000000000000..78b2de4a9ed1
--- /dev/null
+++ b/www/p5-WWW-Mechanize-PhantomJS/pkg-plist
@@ -0,0 +1,75 @@
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS.pm
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/DSL.pm
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/Examples.pm
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/config.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/errors.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/hub_register.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/inputs.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/logger.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/main.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/request_handlers/request_handler.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/request_handlers/router_request_handler.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/request_handlers/session_manager_request_handler.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/request_handlers/session_request_handler.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/request_handlers/shutdown_request_handler.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/request_handlers/status_request_handler.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/request_handlers/webelement_request_handler.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/session.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/console++.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/har.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/parseuri.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/uuid.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/active_element.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/clear.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/clear_local_storage.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/clear_session_storage.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/click.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/double_click.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/drag.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/execute_async_script.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/execute_script.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/execute_sql.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/find_element.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/find_elements.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/focus_on_element.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/get_appcache_status.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/get_attribute.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/get_attribute_value.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/get_current_position.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/get_local_storage_item.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/get_local_storage_keys.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/get_local_storage_size.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/get_location.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/get_location_in_view.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/get_session_storage_item.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/get_session_storage_keys.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/get_session_storage_size.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/get_size.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/get_text.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/get_value_of_css_property.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/is_displayed.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/is_enabled.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/is_online.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/is_selected.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/lastupdate
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/move_mouse.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/pinch.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/remove_local_storage_item.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/remove_session_storage_item.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/right_click.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/rotate.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/scroll_into_view.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/scroll_mouse.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/set_local_storage_item.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/set_session_storage_item.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/submit.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/swipe.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/tap.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/third_party/webdriver-atoms/type.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/webdriver_atoms.js
+%%SITE_PERL%%/WWW/Mechanize/PhantomJS/ghostdriver/webelementlocator.js
+%%SITE_PERL%%/WWW/Mechanize/Plugin/Selector.pm
+%%PERL5_MAN3%%/WWW::Mechanize::PhantomJS.3.gz
+%%PERL5_MAN3%%/WWW::Mechanize::PhantomJS::DSL.3.gz
+%%PERL5_MAN3%%/WWW::Mechanize::PhantomJS::Examples.3.gz
+%%PERL5_MAN3%%/WWW::Mechanize::Plugin::Selector.3.gz