aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Mechanize-Plugin-phpBB/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-05 05:32:16 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-05 05:32:16 +0000
commit90f9becd9d28ddf50af893858641111f120a2982 (patch)
tree9ab6f11b6b18a3bebd04d55c89f2508ceaaf69d5 /www/p5-WWW-Mechanize-Plugin-phpBB/Makefile
parentea6b9222cb98987ea4deb32c5ee5d65946549dc2 (diff)
Adding port www/p5-WWW-Mechanize-Plugin-phpBB, Screen scraper for phpBB installations.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=164383
Diffstat (limited to 'www/p5-WWW-Mechanize-Plugin-phpBB/Makefile')
-rw-r--r--www/p5-WWW-Mechanize-Plugin-phpBB/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/www/p5-WWW-Mechanize-Plugin-phpBB/Makefile b/www/p5-WWW-Mechanize-Plugin-phpBB/Makefile
new file mode 100644
index 000000000000..f372625c3a22
--- /dev/null
+++ b/www/p5-WWW-Mechanize-Plugin-phpBB/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-WWW-Mechanize-Plugin-phpBB
+# Date created: 04 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Mechanize-Plugin-phpBB
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Screen scraper for phpBB installations
+
+BUILD_DEPENDS= ${SITE_PERL}/WWW/Mechanize/Pluggable.pm:${PORTSDIR}/www/p5-WWW-Mechanize-Pluggable \
+ ${SITE_PERL}/HTML/TreeBuilder.pm:${PORTSDIR}/www/p5-HTML-Tree \
+ ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= WWW::Mechanize::Plugin::phpBB.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # inherited from p5-WWW-Mechanize-Pluggable
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>