aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Mechanize-Shell/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-12-06 11:14:01 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-12-06 11:14:01 +0000
commitf320cb9fab9acb1ce757909a945d6b0438a95c11 (patch)
tree7b4285eca0628d90d288d7e5e65ec2ede7531708 /www/p5-WWW-Mechanize-Shell/Makefile
parentdb018514aab327d591b44fe27756e1cb96c090fe (diff)
Notes
Diffstat (limited to 'www/p5-WWW-Mechanize-Shell/Makefile')
-rw-r--r--www/p5-WWW-Mechanize-Shell/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/www/p5-WWW-Mechanize-Shell/Makefile b/www/p5-WWW-Mechanize-Shell/Makefile
index c3a558f5aa34..a2ea763de487 100644
--- a/www/p5-WWW-Mechanize-Shell/Makefile
+++ b/www/p5-WWW-Mechanize-Shell/Makefile
@@ -4,7 +4,7 @@
# $FreeBSD$
PORTNAME= WWW-Mechanize-Shell
-PORTVERSION= 0.34
+PORTVERSION= 0.36
PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
@@ -43,6 +43,18 @@ MAN3= HTML::Display.3 \
HTML::Display::Win32::OLE.3 \
WWW::Mechanize::Shell.3
+.if !defined(NOPORTDOCS)
+PORTDOCS= Changes README
+EXAMPLES= bin/banking.postbank.de.mech bin/hotmail.signup.mech bin/wwwshell.pl
+
+post-install:
+ @${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ @${INSTALL_DATA} ${EXAMPLES:S|^|${WRKSRC}/|} ${EXAMPLESDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${EXAMPLESDIR}."
+.endif
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500601