aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Mixi-Scraper/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-01-07 02:57:46 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-01-07 02:57:46 +0000
commit27bf9f0b416dd04d04292fa4102835c73c28ad80 (patch)
tree3e82b0e9f0c69c5f1bccee42ff138b7bf2bdede4 /www/p5-WWW-Mixi-Scraper/Makefile
parent99ef42d867cfaf54914a1948593072bb48195cea (diff)
downloadports-27bf9f0b416dd04d04292fa4102835c73c28ad80.tar.gz
ports-27bf9f0b416dd04d04292fa4102835c73c28ad80.zip
Notes
Diffstat (limited to 'www/p5-WWW-Mixi-Scraper/Makefile')
-rw-r--r--www/p5-WWW-Mixi-Scraper/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/www/p5-WWW-Mixi-Scraper/Makefile b/www/p5-WWW-Mixi-Scraper/Makefile
new file mode 100644
index 000000000000..ca98188afd65
--- /dev/null
+++ b/www/p5-WWW-Mixi-Scraper/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: p5-WWW-Mixi-Scraper
+# Date created: 2007-12-28
+# Whom: Masahiro Teramoto <markun@onohara.to>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Mixi-Scraper
+PORTVERSION= 0.11
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/I/IS/ISHIGAKI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= markun@onohara.to
+COMMENT= Yet another mixi scraper
+
+BUILD_DEPENDS= p5-Encode>=0:${PORTSDIR}/converters/p5-Encode \
+ p5-Module-Pluggable-Fast>=0:${PORTSDIR}/devel/p5-Module-Pluggable-Fast \
+ p5-String-CamelCase>=0:${PORTSDIR}/textproc/p5-String-CamelCase \
+ p5-Test-UseAllModules>=0:${PORTSDIR}/devel/p5-Test-UseAllModules \
+ p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-Web-Scraper>=0.17:${PORTSDIR}/www/p5-Web-Scraper \
+ p5-WWW-Mechanize>=1.30:${PORTSDIR}/www/p5-WWW-Mechanize \
+ p5-WWW-Mechanize-DecodedContent>=0:${PORTSDIR}/www/p5-WWW-Mechanize-DecodedContent
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Mixi::Scraper::Utils.3 \
+ WWW::Mixi::Scraper::Plugin::NewMusic.3 \
+ WWW::Mixi::Scraper::Plugin::NewBBS.3 \
+ WWW::Mixi::Scraper::Plugin::ListComment.3 \
+ WWW::Mixi::Scraper::Mech.3 \
+ WWW::Mixi::Scraper::Plugin::ListMessage.3 \
+ WWW::Mixi::Scraper::Plugin::ShowFriend.3 \
+ WWW::Mixi::Scraper::Plugin::ViewEvent.3 \
+ WWW::Mixi::Scraper::Plugin::ShowLog.3 \
+ WWW::Mixi::Scraper::Plugin::ListDiary.3 \
+ WWW::Mixi::Scraper::Plugin::ShowCalendar.3 \
+ WWW::Mixi::Scraper::Plugin::ViewMessage.3 \
+ WWW::Mixi::Scraper::Plugin.3 \
+ WWW::Mixi::Scraper.3 \
+ WWW::Mixi::Scraper::Plugin::NewFriendDiary.3 \
+ WWW::Mixi::Scraper::Plugin::ViewDiary.3 \
+ WWW::Mixi::Scraper::Plugin::ViewBBS.3 \
+ WWW::Mixi::Scraper::Plugin::NewVideo.3
+
+.include <bsd.port.mk>