aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Myspace
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-10 15:06:35 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-10 15:06:35 +0000
commit2555fb976cc87195bc22ab937d055ca31a9d02b6 (patch)
treedb86e58c3a5c7ff7490133277c83775330f2f34d /www/p5-WWW-Myspace
parent209521709485a2299e648f9d2da0954f66c22200 (diff)
downloadports-2555fb976cc87195bc22ab937d055ca31a9d02b6.tar.gz
ports-2555fb976cc87195bc22ab937d055ca31a9d02b6.zip
Notes
Diffstat (limited to 'www/p5-WWW-Myspace')
-rw-r--r--www/p5-WWW-Myspace/Makefile48
-rw-r--r--www/p5-WWW-Myspace/distinfo3
-rw-r--r--www/p5-WWW-Myspace/pkg-descr6
-rw-r--r--www/p5-WWW-Myspace/pkg-plist17
4 files changed, 74 insertions, 0 deletions
diff --git a/www/p5-WWW-Myspace/Makefile b/www/p5-WWW-Myspace/Makefile
new file mode 100644
index 000000000000..14d0925ba922
--- /dev/null
+++ b/www/p5-WWW-Myspace/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: p5-WWW-Myspace
+# Date created: 2006-08-09
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Myspace
+PORTVERSION= 0.52
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Access MySpace.com profile information from Perl
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI \
+ ${SITE_PERL}/Class/DBI/AbstractSearch.pm:${PORTSDIR}/databases/p5-Class-DBI-AbstractSearch \
+ ${SITE_PERL}/Class/DBI/Loader.pm:${PORTSDIR}/databases/p5-Class-DBI-Loader \
+ ${SITE_PERL}/Config/General.pm:${PORTSDIR}/devel/p5-Config-General \
+ ${SITE_PERL}/Contextual/Return.pm:${PORTSDIR}/devel/p5-Contextual-Return \
+ ${SITE_PERL}/DateTime/Format/MySQL.pm:${PORTSDIR}/devel/p5-DateTime-Format-MySQL \
+ ${SITE_PERL}/IO/Prompt.pm:${PORTSDIR}/devel/p5-IO-Prompt \
+ ${SITE_PERL}/List/Compare.pm:${PORTSDIR}/misc/p5-List-Compare \
+ ${SITE_PERL}/Locale/SubCountry.pm:${PORTSDIR}/misc/p5-Locale-SubCountry \
+ ${SITE_PERL}/Math/Round.pm:${PORTSDIR}/math/p5-Math-Round \
+ ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize \
+ p5-Spiffy>=0.24:${PORTSDIR}/devel/p5-Spiffy \
+ p5-YAML>=0.39:${PORTSDIR}/textproc/p5-YAML
+
+PERL_CONFIGURE= yes
+
+MAN1= add_friends.1 approve_friends.1 comment_myspace.1 \
+ message_group.1
+MAN3= WWW::Myspace.3 WWW::Myspace::Comment.3 WWW::Myspace::Data.3 \
+ WWW::Myspace::FriendAdder.3 WWW::Myspace::FriendChanges.3 \
+ WWW::Myspace::Message.3 WWW::Myspace::MyBase.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # Inherited from depends
+IGNORE= requires Perl 5.6.0 or newer. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-Myspace/distinfo b/www/p5-WWW-Myspace/distinfo
new file mode 100644
index 000000000000..b0f6d4cd8975
--- /dev/null
+++ b/www/p5-WWW-Myspace/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-Myspace-0.52.tar.gz) = b11e8bf3ff5537b1903825a733da87ed
+SHA256 (WWW-Myspace-0.52.tar.gz) = 7480aac2a8909c2b3ef4be8663ff085260653bd2c608e0184fb3be9a1b677985
+SIZE (WWW-Myspace-0.52.tar.gz) = 108449
diff --git a/www/p5-WWW-Myspace/pkg-descr b/www/p5-WWW-Myspace/pkg-descr
new file mode 100644
index 000000000000..adf681afd7b5
--- /dev/null
+++ b/www/p5-WWW-Myspace/pkg-descr
@@ -0,0 +1,6 @@
+WWW::Myspace.pm provides methods to access your myspace.com account
+and functions automatically. It provides a simple interface for
+scripts to log in, access lists of friends, scan user's profiles,
+retreive profile data, send messages, and post comments.
+
+WWW: http://search.cpan.org/dist/WWW-Myspace/
diff --git a/www/p5-WWW-Myspace/pkg-plist b/www/p5-WWW-Myspace/pkg-plist
new file mode 100644
index 000000000000..906d5cf33514
--- /dev/null
+++ b/www/p5-WWW-Myspace/pkg-plist
@@ -0,0 +1,17 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Myspace/.packlist
+%%SITE_PERL%%/WWW/Myspace.pm
+%%SITE_PERL%%/WWW/Myspace/Comment.pm
+%%SITE_PERL%%/WWW/Myspace/Data.pm
+%%SITE_PERL%%/WWW/Myspace/FriendAdder.pm
+%%SITE_PERL%%/WWW/Myspace/FriendChanges.pm
+%%SITE_PERL%%/WWW/Myspace/Message.pm
+%%SITE_PERL%%/WWW/Myspace/MyBase.pm
+bin/add_friends
+bin/approve_friends
+bin/comment_myspace
+bin/message_group
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Myspace
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+@dirrmtry %%SITE_PERL%%/WWW/Myspace
+@dirrmtry %%SITE_PERL%%/WWW