aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-NioTV
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-08-31 16:45:27 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-08-31 16:45:27 +0000
commitedc416d5829c9aad3986ce5158f71796d4032dd8 (patch)
tree7599fc8b9fd86d41998f4bb28f3e0715937cdd42 /www/p5-WWW-NioTV
parente13c2cb53bfac07e30eef3deea9e161f1a798034 (diff)
Notes
Diffstat (limited to 'www/p5-WWW-NioTV')
-rw-r--r--www/p5-WWW-NioTV/Makefile31
-rw-r--r--www/p5-WWW-NioTV/distinfo3
-rw-r--r--www/p5-WWW-NioTV/pkg-descr3
-rw-r--r--www/p5-WWW-NioTV/pkg-plist5
4 files changed, 42 insertions, 0 deletions
diff --git a/www/p5-WWW-NioTV/Makefile b/www/p5-WWW-NioTV/Makefile
new file mode 100644
index 000000000000..136a6083ad99
--- /dev/null
+++ b/www/p5-WWW-NioTV/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-WWW-NioTV
+# Date created: 2008/08/31
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-NioTV
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Retrieve TV information from http://www.niotv.com/
+
+BUILD_DEPENDS= p5-HTML-SimpleLinkExtor>=0:${PORTSDIR}/www/p5-HTML-SimpleLinkExtor \
+ p5-HTML-TableExtract>=0:${PORTSDIR}/www/p5-HTML-TableExtract \
+ p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize \
+ p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Moose>=0.25:${PORTSDIR}/devel/p5-Moose \
+ p5-version>=0:${PORTSDIR}/devel/p5-version \
+ p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::NioTV.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-NioTV/distinfo b/www/p5-WWW-NioTV/distinfo
new file mode 100644
index 000000000000..05583797f490
--- /dev/null
+++ b/www/p5-WWW-NioTV/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-NioTV-v0.02.tar.gz) = 6a0efcd7b257154cf7d9f0ae9e8e655b
+SHA256 (WWW-NioTV-v0.02.tar.gz) = 8c9c44aa9075c650149bc222db980a6ebfc235ddb2d2f9d600ddc93c54aafbdb
+SIZE (WWW-NioTV-v0.02.tar.gz) = 4502
diff --git a/www/p5-WWW-NioTV/pkg-descr b/www/p5-WWW-NioTV/pkg-descr
new file mode 100644
index 000000000000..b2eb14015abb
--- /dev/null
+++ b/www/p5-WWW-NioTV/pkg-descr
@@ -0,0 +1,3 @@
+WWW::NioTV - retrieve TV information from http://www.niotv.com/
+
+WWW: http://search.cpan.org/dist/WWW-NioTV/
diff --git a/www/p5-WWW-NioTV/pkg-plist b/www/p5-WWW-NioTV/pkg-plist
new file mode 100644
index 000000000000..6273869f825a
--- /dev/null
+++ b/www/p5-WWW-NioTV/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/NioTV/.packlist
+%%SITE_PERL%%/WWW/NioTV.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/NioTV
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+@dirrmtry %%SITE_PERL%%/WWW