aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Scraper-ISBN-Driver
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-11-09 14:18:11 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-11-09 14:18:11 +0000
commitd43bfdaf19b255b9cc6c4bef5f74e502217df1b9 (patch)
treef60c2aa1e50d6c5cf5f3972013671b50a45db702 /www/p5-WWW-Scraper-ISBN-Driver
parent7cc78f06e8acee57f80a516f27870470c5bcbef6 (diff)
This is a base class, all site-specific drivers should inherit its members
and methods. Driver subclasses named '$name' should be packaged as WWW::Scraper::ISBN::$name_Driver, e.g. WWW::Scraper::ISBN::LOC_Driver for LOC (Library of Congress) driver. Each driver need only implement the search() method, though they may have as many other methods as they need to get their job done. Only search() will be called by WWW::Scraper::ISBN->search(). WWW: http://search.cpan.org/dist/WWW-Scraper-ISBN-Driver/ PR: ports/88668 Submitted by: Ying-Chieh Liao <ijliao@csie.nctu.edu.tw>
Notes
Notes: svn path=/head/; revision=147707
Diffstat (limited to 'www/p5-WWW-Scraper-ISBN-Driver')
-rw-r--r--www/p5-WWW-Scraper-ISBN-Driver/Makefile28
-rw-r--r--www/p5-WWW-Scraper-ISBN-Driver/distinfo3
-rw-r--r--www/p5-WWW-Scraper-ISBN-Driver/pkg-descr9
-rw-r--r--www/p5-WWW-Scraper-ISBN-Driver/pkg-plist9
4 files changed, 49 insertions, 0 deletions
diff --git a/www/p5-WWW-Scraper-ISBN-Driver/Makefile b/www/p5-WWW-Scraper-ISBN-Driver/Makefile
new file mode 100644
index 000000000000..c4be90afa9db
--- /dev/null
+++ b/www/p5-WWW-Scraper-ISBN-Driver/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: p5-WWW-Scraper-ISBN-Driver
+# Date created: Nov 8, 2005
+# Whom: Ying-Chieh Liao <ijliao@csie.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Scraper-ISBN-Driver
+PORTVERSION= 0.18
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Driver class for WWW::Scraper::ISBN module
+
+PERL_CONFIGURE= YES
+
+MAN3= WWW::Scraper::ISBN::Driver.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "Requires perl 5.6.x or higher"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-Scraper-ISBN-Driver/distinfo b/www/p5-WWW-Scraper-ISBN-Driver/distinfo
new file mode 100644
index 000000000000..6c91d90eaadd
--- /dev/null
+++ b/www/p5-WWW-Scraper-ISBN-Driver/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-Scraper-ISBN-Driver-0.18.tar.gz) = 0b2afef8d162721b7e224d17e75a40c3
+SHA256 (WWW-Scraper-ISBN-Driver-0.18.tar.gz) = 527dfaebf7ebc1308a66c8ff25355abf92505795ead5b185170394385b36458e
+SIZE (WWW-Scraper-ISBN-Driver-0.18.tar.gz) = 3907
diff --git a/www/p5-WWW-Scraper-ISBN-Driver/pkg-descr b/www/p5-WWW-Scraper-ISBN-Driver/pkg-descr
new file mode 100644
index 000000000000..4d2adf396423
--- /dev/null
+++ b/www/p5-WWW-Scraper-ISBN-Driver/pkg-descr
@@ -0,0 +1,9 @@
+This is a base class, all site-specific drivers should inherit its members
+and methods. Driver subclasses named '$name' should be packaged as
+WWW::Scraper::ISBN::$name_Driver, e.g. WWW::Scraper::ISBN::LOC_Driver for
+LOC (Library of Congress) driver. Each driver need only implement the
+search() method, though they may have as many other methods as they need to
+get their job done. Only search() will be called by
+WWW::Scraper::ISBN->search().
+
+WWW: http://search.cpan.org/dist/WWW-Scraper-ISBN-Driver/
diff --git a/www/p5-WWW-Scraper-ISBN-Driver/pkg-plist b/www/p5-WWW-Scraper-ISBN-Driver/pkg-plist
new file mode 100644
index 000000000000..966650c8350c
--- /dev/null
+++ b/www/p5-WWW-Scraper-ISBN-Driver/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/WWW/Scraper/ISBN/Driver.pm
+@unexec rmdir %D/%%SITE_PERL%%/WWW/Scraper/ISBN 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/WWW/Scraper 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/WWW 2>/dev/null || true
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Scraper/ISBN/Driver/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Scraper/ISBN/Driver 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Scraper/ISBN 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Scraper 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW 2>/dev/null || true