aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Scraper-ISBN-Record/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-11-09 14:18:51 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-11-09 14:18:51 +0000
commitb25393156623a8afd71d44a483846f2bbe437e5f (patch)
tree9736a61cb2cb370729dfe8494eead7f1731bb89f /www/p5-WWW-Scraper-ISBN-Record/Makefile
parentd43bfdaf19b255b9cc6c4bef5f74e502217df1b9 (diff)
The WWW::Scraper::ISBN::Record module defines a class that can be used to deal
with book information. It was primarily created as a return type for the WWW::Scraper::ISBN module, though it could be used for other purposes. It knows minimal information about itself, whether the book was found, where it was found, its ISBN number, and whether any errors occurred. It is usually up to the WWW::Scraper::ISBN::Driver and its subclasses to make sure that the fields get set correctly. WWW: http://search.cpan.org/dist/WWW-Scraper-ISBN-Record/ PR: ports/88666 Submitted by: Ying-Chieh Liao <ijliao@csie.nctu.edu.tw>
Notes
Notes: svn path=/head/; revision=147709
Diffstat (limited to 'www/p5-WWW-Scraper-ISBN-Record/Makefile')
-rw-r--r--www/p5-WWW-Scraper-ISBN-Record/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/www/p5-WWW-Scraper-ISBN-Record/Makefile b/www/p5-WWW-Scraper-ISBN-Record/Makefile
new file mode 100644
index 000000000000..bd34c9136c6f
--- /dev/null
+++ b/www/p5-WWW-Scraper-ISBN-Record/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: p5-WWW-Scraper-ISBN-Record
+# Date created: Nov 8, 2005
+# Whom: Ying-Chieh Liao <ijliao@csie.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Scraper-ISBN-Record
+PORTVERSION= 0.17
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Book Record class for WWW::Scraper::ISBN module
+
+PERL_CONFIGURE= YES
+
+MAN3= WWW::Scraper::ISBN::Record.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "Requires perl 5.6.x or higher"
+.endif
+
+.include <bsd.port.post.mk>