aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Shorten-NotLong/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-25 19:26:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-25 19:26:55 +0000
commit201645c25dda7034b133481f34bbfe18f52c913e (patch)
tree0d4304a232c83db34a04d2499ad4d446a43f087a /www/p5-WWW-Shorten-NotLong/Makefile
parentd29f9efe58783bac0362f2c67f8b9670afabcf15 (diff)
downloadports-201645c25dda7034b133481f34bbfe18f52c913e.tar.gz
ports-201645c25dda7034b133481f34bbfe18f52c913e.zip
Notes
Diffstat (limited to 'www/p5-WWW-Shorten-NotLong/Makefile')
-rw-r--r--www/p5-WWW-Shorten-NotLong/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/p5-WWW-Shorten-NotLong/Makefile b/www/p5-WWW-Shorten-NotLong/Makefile
new file mode 100644
index 000000000000..3c8aa3a1afa5
--- /dev/null
+++ b/www/p5-WWW-Shorten-NotLong/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-WWW-Shorten-NotLong
+# Date created: November 24 2009
+# Whom: Sahil Tandon <sahil@tandon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Shorten-NotLong
+PORTVERSION= 2.00
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sahil@tandon.net
+COMMENT= A Perl interface to the web site notlong.com
+
+BUILD_DEPENDS= p5-libwww>=5.75:${PORTSDIR}/www/p5-libwww \
+ p5-URI>=1.27:${PORTSDIR}/net/p5-URI \
+ p5-WWW-Shorten>=0:${PORTSDIR}/www/p5-WWW-Shorten
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= WWW::Shorten::NotLong.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>