aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Spinn3r/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-26 15:16:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-26 15:16:58 +0000
commit08f8396490051fba8bd974aef70d2e9324fb0676 (patch)
treecc593274f7f60ccb923d6c9f1aa095e7a1e85da9 /www/p5-WWW-Spinn3r/Makefile
parentf713f274ef32b9a91e6fb934f78cf5caef0b81ed (diff)
Notes
Diffstat (limited to 'www/p5-WWW-Spinn3r/Makefile')
-rw-r--r--www/p5-WWW-Spinn3r/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/p5-WWW-Spinn3r/Makefile b/www/p5-WWW-Spinn3r/Makefile
new file mode 100644
index 000000000000..11f1320bba18
--- /dev/null
+++ b/www/p5-WWW-Spinn3r/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-WWW-Spinn3r
+# Date created: 2008-03-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Spinn3r
+PORTVERSION= 2.00100302
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= An interface to the Spinn3r API
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Spinn3r.3
+
+.include <bsd.port.mk>