aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-VenusEnvy
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-19 02:25:46 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-19 02:25:46 +0000
commitec4b5ec340ffc8e9ac42cdf926ce9e5e1445cc6a (patch)
tree3fd8d82e3c84a21104f1f2205ba3c8431096c9d8 /www/p5-WWW-VenusEnvy
parent19a8c3cc6a281e5ad0b821cc21a6b8b043a72c8e (diff)
downloadports-ec4b5ec340ffc8e9ac42cdf926ce9e5e1445cc6a.tar.gz
ports-ec4b5ec340ffc8e9ac42cdf926ce9e5e1445cc6a.zip
Notes
Diffstat (limited to 'www/p5-WWW-VenusEnvy')
-rw-r--r--www/p5-WWW-VenusEnvy/Makefile34
-rw-r--r--www/p5-WWW-VenusEnvy/distinfo3
-rw-r--r--www/p5-WWW-VenusEnvy/pkg-descr5
-rw-r--r--www/p5-WWW-VenusEnvy/pkg-plist3
4 files changed, 45 insertions, 0 deletions
diff --git a/www/p5-WWW-VenusEnvy/Makefile b/www/p5-WWW-VenusEnvy/Makefile
new file mode 100644
index 000000000000..c1f6e21d3ace
--- /dev/null
+++ b/www/p5-WWW-VenusEnvy/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-WWW-VenusEnvy
+# Date created: 2006/06/28
+# Whom: chinsan <chinsan.tw@gmail.com>, Gea-Suan Lin <gslin@gslin.org>
+# Thanks to Gea-Suan Lin for his great patch for this port.
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-VenusEnvy
+PORTVERSION= 1.10
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= VenusEnvy comic strip archive and retrieval module
+
+RUN_DEPENDS= p5-Test-Pod>=1.24:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>=1.08:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
+ p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= WWW::VenusEnvy.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # Inherited from www/p5-libwww
+IGNORE= requires at least Perl 5.6.0. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-VenusEnvy/distinfo b/www/p5-WWW-VenusEnvy/distinfo
new file mode 100644
index 000000000000..0b0cb5b4594c
--- /dev/null
+++ b/www/p5-WWW-VenusEnvy/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-VenusEnvy-1.10.tar.gz) = 15926752f71ac3e15a3513f2c2532633
+SHA256 (WWW-VenusEnvy-1.10.tar.gz) = 37d18dffdb90c1f4cb9eeac77ea0803cb668340f7f7e1083f83db5168a76c8d9
+SIZE (WWW-VenusEnvy-1.10.tar.gz) = 10321
diff --git a/www/p5-WWW-VenusEnvy/pkg-descr b/www/p5-WWW-VenusEnvy/pkg-descr
new file mode 100644
index 000000000000..4182ef867d56
--- /dev/null
+++ b/www/p5-WWW-VenusEnvy/pkg-descr
@@ -0,0 +1,5 @@
+This module will download the latest VenusEnvy comic strip
+from the Keenspace website and return a binary blob of the image, or write
+it to disk.
+
+WWW: http://search.cpan.org/dist/WWW-VenusEnvy/
diff --git a/www/p5-WWW-VenusEnvy/pkg-plist b/www/p5-WWW-VenusEnvy/pkg-plist
new file mode 100644
index 000000000000..98f719854f12
--- /dev/null
+++ b/www/p5-WWW-VenusEnvy/pkg-plist
@@ -0,0 +1,3 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/WWW/VenusEnvy.pm
+@dirrmtry %%SITE_PERL%%/WWW