aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Web-oEmbed
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-02-05 09:39:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-02-05 09:39:32 +0000
commita6588114aa2c6115a22b4f1374e0439609acaf9d (patch)
tree21d30193205748a6e87456157d52005c428c2843 /www/p5-Web-oEmbed
parent50c58122249ecb6c8d89c2b5db1ea13084e328f1 (diff)
downloadports-a6588114aa2c6115a22b4f1374e0439609acaf9d.tar.gz
ports-a6588114aa2c6115a22b4f1374e0439609acaf9d.zip
Notes
Diffstat (limited to 'www/p5-Web-oEmbed')
-rw-r--r--www/p5-Web-oEmbed/Makefile27
-rw-r--r--www/p5-Web-oEmbed/distinfo2
-rw-r--r--www/p5-Web-oEmbed/pkg-descr3
-rw-r--r--www/p5-Web-oEmbed/pkg-plist8
4 files changed, 40 insertions, 0 deletions
diff --git a/www/p5-Web-oEmbed/Makefile b/www/p5-Web-oEmbed/Makefile
new file mode 100644
index 000000000000..ebf9b84d6d43
--- /dev/null
+++ b/www/p5-Web-oEmbed/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Web-oEmbed
+# Date created: 2011-01-14
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Web-oEmbed
+PORTVERSION= 0.04
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= oEmbed consumer
+
+RUN_DEPENDS= p5-Any-Moose>=0:${PORTSDIR}/devel/p5-Any-Moose \
+ p5-HTML-Tree>=0:${PORTSDIR}/www/p5-HTML-Tree \
+ p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-XML-LibXML-Simple>=0:${PORTSDIR}/textproc/p5-XML-LibXML-Simple \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Web::oEmbed.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Web-oEmbed/distinfo b/www/p5-Web-oEmbed/distinfo
new file mode 100644
index 000000000000..232a5e8a3ec7
--- /dev/null
+++ b/www/p5-Web-oEmbed/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Web-oEmbed-0.04.tar.gz) = c979d007ff6ba161ebcc0e899de55279dbe0d10ebb127bf291a626b85a08a9c2
+SIZE (Web-oEmbed-0.04.tar.gz) = 42018
diff --git a/www/p5-Web-oEmbed/pkg-descr b/www/p5-Web-oEmbed/pkg-descr
new file mode 100644
index 000000000000..ade1a0fe37c4
--- /dev/null
+++ b/www/p5-Web-oEmbed/pkg-descr
@@ -0,0 +1,3 @@
+Web::oEmbed is a module that implements oEmbed consumer.
+
+WWW: http://search.cpan.org/dist/Web-oEmbed/
diff --git a/www/p5-Web-oEmbed/pkg-plist b/www/p5-Web-oEmbed/pkg-plist
new file mode 100644
index 000000000000..ca2431b8863b
--- /dev/null
+++ b/www/p5-Web-oEmbed/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Web/oEmbed/.packlist
+%%SITE_PERL%%/Web/oEmbed.pm
+%%SITE_PERL%%/Web/oEmbed/Response.pm
+@dirrmtry %%SITE_PERL%%/Web/oEmbed
+@dirrmtry %%SITE_PERL%%/Web
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Web/oEmbed
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Web