aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WebService-Basecamp
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-22 06:30:05 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-22 06:30:05 +0000
commitfbb96e7992a309506257a3184cc2b30205390a0c (patch)
treeaccf60840d15e4a6c92c4f231821730984fed479 /www/p5-WebService-Basecamp
parentca30180fce2f855e8628b4b985f7751277861ae2 (diff)
downloadports-fbb96e7992a309506257a3184cc2b30205390a0c.tar.gz
ports-fbb96e7992a309506257a3184cc2b30205390a0c.zip
Notes
Diffstat (limited to 'www/p5-WebService-Basecamp')
-rw-r--r--www/p5-WebService-Basecamp/Makefile31
-rw-r--r--www/p5-WebService-Basecamp/distinfo3
-rw-r--r--www/p5-WebService-Basecamp/pkg-descr21
-rw-r--r--www/p5-WebService-Basecamp/pkg-plist6
4 files changed, 61 insertions, 0 deletions
diff --git a/www/p5-WebService-Basecamp/Makefile b/www/p5-WebService-Basecamp/Makefile
new file mode 100644
index 000000000000..cc3d0f7e18c2
--- /dev/null
+++ b/www/p5-WebService-Basecamp/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-WebService-Basecamp
+# Date created: 2006-08-18
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WebService-Basecamp
+PORTVERSION= 0.1.1
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WebService
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl interface to the Basecamp API webservice
+
+RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
+
+PERL_CONFIGURE= yes
+
+MAN3= WebService::Basecamp.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # Inherited from www/p5-libwww
+IGNORE= requires Perl 5.6.0 or newer. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WebService-Basecamp/distinfo b/www/p5-WebService-Basecamp/distinfo
new file mode 100644
index 000000000000..2592c2b49041
--- /dev/null
+++ b/www/p5-WebService-Basecamp/distinfo
@@ -0,0 +1,3 @@
+MD5 (WebService-Basecamp-0.1.1.tar.gz) = 85beddbdd1ce6e4d87a5eef066a95dbc
+SHA256 (WebService-Basecamp-0.1.1.tar.gz) = 284bba537743326ba883102017332f4373efebc6682c2ab9452c6f34b3411a4a
+SIZE (WebService-Basecamp-0.1.1.tar.gz) = 23204
diff --git a/www/p5-WebService-Basecamp/pkg-descr b/www/p5-WebService-Basecamp/pkg-descr
new file mode 100644
index 000000000000..59cb367477af
--- /dev/null
+++ b/www/p5-WebService-Basecamp/pkg-descr
@@ -0,0 +1,21 @@
+Basecamp is a web based project collaboration tool that makes it
+simple to communicate and collaborate on projects. Basecamp is built
+on the Ruby on Rails platform but provides a webservice API to many of
+the application functions. WebService::Basecamp is a Perl interface to
+the Basecamp web service API.
+
+For more information on Basecamp, visit the Basecamp website.
+http://www.basecamphq.com.
+
+This module does much of the heavy lifting for you when accessing the
+Basecamp API. Once initialising a WebService::Basecamp object you can
+access the API function via method calls. The module takes care of the
+creation and parsing of the XML (using XML::Simple) that relays the
+data across the web service, however there is an option to access the
+XML directly (see new()).
+
+The documentation for this module is based on the Basecamp API docs
+available at http://www.basecamphq.com/api. It is recommended you read
+the official docs to become familiar with the data reference.
+
+WWW: http://search.cpan.org/dist/WebService-Basecamp/
diff --git a/www/p5-WebService-Basecamp/pkg-plist b/www/p5-WebService-Basecamp/pkg-plist
new file mode 100644
index 000000000000..c52287bf0be0
--- /dev/null
+++ b/www/p5-WebService-Basecamp/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Basecamp/.packlist
+%%SITE_PERL%%/WebService/Basecamp.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Basecamp
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService
+@dirrmtry %%SITE_PERL%%/WebService