aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WebService-Bloglines/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2005-02-17 14:31:57 +0000
committerMathieu Arnold <mat@FreeBSD.org>2005-02-17 14:31:57 +0000
commitb0e9a943d9444584c4fb22bc3e78e0431bb22354 (patch)
tree4339fb73bdeb353d60787c3db58680232d490339 /www/p5-WebService-Bloglines/Makefile
parenta9e14b00d4b760da258dabcb487ec6aab11cc52f (diff)
downloadports-b0e9a943d9444584c4fb22bc3e78e0431bb22354.tar.gz
ports-b0e9a943d9444584c4fb22bc3e78e0431bb22354.zip
Notes
Diffstat (limited to 'www/p5-WebService-Bloglines/Makefile')
-rw-r--r--www/p5-WebService-Bloglines/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/www/p5-WebService-Bloglines/Makefile b/www/p5-WebService-Bloglines/Makefile
index be2f6a796209..bfd76bfcac44 100644
--- a/www/p5-WebService-Bloglines/Makefile
+++ b/www/p5-WebService-Bloglines/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= WebService-Bloglines
-PORTVERSION= 0.04
+PORTVERSION= 0.05
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= WebService
@@ -17,11 +17,19 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Easy-to-use Interface for Bloglines Web Services
BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS
+ ${SITE_PERL}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS \
+ ${SITE_PERL}/XML/XPath.pm:${PORTSDIR}/textproc/p5-XML-XPath
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= WebService::Bloglines.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# XML::RSS -> XML::Parser -> Test::Manifest which needs 5.6
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>