aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WebService-Linode
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-09-23 02:41:19 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-09-23 02:41:19 +0000
commit99c6b633018908c32e9d1f76d847e6a01c3817f8 (patch)
tree3a175d458a231ae9c183cd778fb7ec8f6267c777 /www/p5-WebService-Linode
parent754a686ae956ba9ca367d1e24f8ddbd4487b0aa5 (diff)
Notes
Diffstat (limited to 'www/p5-WebService-Linode')
-rw-r--r--www/p5-WebService-Linode/Makefile28
-rw-r--r--www/p5-WebService-Linode/distinfo3
-rw-r--r--www/p5-WebService-Linode/pkg-descr6
-rw-r--r--www/p5-WebService-Linode/pkg-plist9
4 files changed, 46 insertions, 0 deletions
diff --git a/www/p5-WebService-Linode/Makefile b/www/p5-WebService-Linode/Makefile
new file mode 100644
index 000000000000..434c44626f4c
--- /dev/null
+++ b/www/p5-WebService-Linode/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-WebService-Linode
+# Date created: 2010-09-20
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WebService-Linode
+PORTVERSION= 0.05
+CATEGORIES= www
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= WebService
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl Interface to the Linode.com API
+
+RUN_DEPENDS= p5-Crypt-SSLeay>0:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ p5-JSON>0:${PORTSDIR}/converters/p5-JSON \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= WebService::Linode.3 \
+ WebService::Linode::Base.3 \
+ WebService::Linode::DNS.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-WebService-Linode/distinfo b/www/p5-WebService-Linode/distinfo
new file mode 100644
index 000000000000..9a42bd374772
--- /dev/null
+++ b/www/p5-WebService-Linode/distinfo
@@ -0,0 +1,3 @@
+MD5 (WebService-Linode-0.05.tar.gz) = 946d299c2dec9d39b8f4927a73d83c8d
+SHA256 (WebService-Linode-0.05.tar.gz) = b604a61b841a95a98cdfadf9f975d151c6fff9972425f93a3f29353010c6a1f9
+SIZE (WebService-Linode-0.05.tar.gz) = 12039
diff --git a/www/p5-WebService-Linode/pkg-descr b/www/p5-WebService-Linode/pkg-descr
new file mode 100644
index 000000000000..e0be6425128b
--- /dev/null
+++ b/www/p5-WebService-Linode/pkg-descr
@@ -0,0 +1,6 @@
+This module implements the Linode.com api methods. Linode methods have
+had dots replaced with underscores to generate the perl method name.
+All keys and parameters have been lower cased but returned data
+remains otherwise the same.
+
+WWW: http://search.cpan.org/dist/WebService-Linode/
diff --git a/www/p5-WebService-Linode/pkg-plist b/www/p5-WebService-Linode/pkg-plist
new file mode 100644
index 000000000000..54841b287a83
--- /dev/null
+++ b/www/p5-WebService-Linode/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Linode/.packlist
+%%SITE_PERL%%/WebService/Linode.pm
+%%SITE_PERL%%/WebService/Linode/Base.pm
+%%SITE_PERL%%/WebService/Linode/DNS.pm
+@dirrmtry %%SITE_PERL%%/WebService/Linode
+@dirrmtry %%SITE_PERL%%/WebService
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Linode
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService