aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WebService-NoPaste/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-28 20:59:43 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-28 20:59:43 +0000
commit0518883a013e4321007e24ce62365ef587300886 (patch)
tree8f2839bd7824df10c7bc9114a6ce740de26192c9 /www/p5-WebService-NoPaste/Makefile
parent1a6a2a42ee26cb2452734cc058ce6efb3df889fd (diff)
Add p5-WebService-NoPaste 0.03, a pastebin web application to upload
snippets of text. PR: 90919 Submitted by: Gea-Suan Lin <gslin@gslin.org>
Notes
Notes: svn path=/head/; revision=152297
Diffstat (limited to 'www/p5-WebService-NoPaste/Makefile')
-rw-r--r--www/p5-WebService-NoPaste/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/www/p5-WebService-NoPaste/Makefile b/www/p5-WebService-NoPaste/Makefile
new file mode 100644
index 000000000000..f2747e0ed81d
--- /dev/null
+++ b/www/p5-WebService-NoPaste/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: p5-WebService-NoPaste
+# Date created: 2005-12-26
+# Whom: Gea-Suan Lin <gslin@netnews.NCTU.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WebService-NoPaste
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WebService
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A pastebin web application to upload snippets of text
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/All.pm:${PORTSDIR}/devel/p5-IO-All \
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Spiffy.pm:${PORTSDIR}/devel/p5-Spiffy
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WebService::NoPaste.3
+
+OPTIONS= X11 "Enable X11 Clipboard support" off
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.if defined(WITH_X11)
+BUILD_DEPENDS+= ${SITE_PERL}/Clipboard.pm:${PORTSDIR}/x11/p5-Clipboard
+.else
+EXTRA_PATCHES+= ${FILESDIR}/extrapatch-lib-WebService-NoPaste.pm
+.endif
+
+post-patch:
+ @${PERL} -pi -e "s|/usr/bin/perl|${PERL}|;" ${WRKSRC}/nopaste
+.if !defined(WITH_X11)
+ @${RM} ${WRKSRC}/lib/WebService/NoPaste.pm.orig
+.endif
+
+.include <bsd.port.post.mk>