aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Yahoo-Lifestyle/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-01-18 01:12:48 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-01-18 01:12:48 +0000
commit12879adf3ff2f823c900bb7cd80d8a3e9ed3ba17 (patch)
tree2bdcc6a8538686a73e2d30642eaa027304a55475 /www/p5-Yahoo-Lifestyle/Makefile
parent32b3f016a3c2272f9f56193eacfaab3674a2f091 (diff)
downloadports-12879adf3ff2f823c900bb7cd80d8a3e9ed3ba17.tar.gz
ports-12879adf3ff2f823c900bb7cd80d8a3e9ed3ba17.zip
Notes
Diffstat (limited to 'www/p5-Yahoo-Lifestyle/Makefile')
-rw-r--r--www/p5-Yahoo-Lifestyle/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/www/p5-Yahoo-Lifestyle/Makefile b/www/p5-Yahoo-Lifestyle/Makefile
new file mode 100644
index 000000000000..6def14ffb2f4
--- /dev/null
+++ b/www/p5-Yahoo-Lifestyle/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: www/p5-Yahoo-Lifestyle
+# Date created: 16 Jan 2008
+# Whom: Rong-En Fan <rafan@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Yahoo-Lifestyle
+PORTVERSION= 0.2
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Yahoo
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hcchien@hcchien.org
+COMMENT= A simple interface for Yahoo! Taiwan Lifestyle open APIs
+
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= p5-Yahoo-BBAuth>=0:${PORTSDIR}/security/p5-Yahoo-BBAuth \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
+
+USE_PERL5= 5.8.1+
+PERL_CONFIGURE= yes
+
+MAN3= Yahoo::Lifestyle.3
+
+.include <bsd.port.mk>