aboutsummaryrefslogtreecommitdiff
path: root/www/p5-libapreq2/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2005-12-25 17:16:59 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2005-12-25 17:16:59 +0000
commit0103a405f696846d6ea8abdabad22bfb40155b64 (patch)
treef371446162355d8cdd319ff942c64c5b25c273cb /www/p5-libapreq2/Makefile
parent0ea01d38b7592b292351dac441484b881e863d23 (diff)
downloadports-0103a405f696846d6ea8abdabad22bfb40155b64.tar.gz
ports-0103a405f696846d6ea8abdabad22bfb40155b64.zip
Notes
Diffstat (limited to 'www/p5-libapreq2/Makefile')
-rw-r--r--www/p5-libapreq2/Makefile36
1 files changed, 4 insertions, 32 deletions
diff --git a/www/p5-libapreq2/Makefile b/www/p5-libapreq2/Makefile
index e82c426bc28f..cc78500087e6 100644
--- a/www/p5-libapreq2/Makefile
+++ b/www/p5-libapreq2/Makefile
@@ -5,41 +5,13 @@
# $FreeBSD$
#
-PORTNAME= libapreq2
-PORTVERSION= 2.06
CATEGORIES= www perl5 devel
-MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
-MASTER_SITE_SUBDIR=libapreq
-PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-${PORTVERSION}-dev
MAINTAINER= ports@FreeBSD.org
-COMMENT= Generic Apache2 Request Library
+COMMENT= Generic Apache2 Request Library with perl binding
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2 \
- ${SITE_PERL}/ExtUtils/XSBuilder:${PORTSDIR}/devel/p5-ExtUtils-XSBuilder \
- ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
-RUN_DEPENDS= ${BUILD_DEPENDS}
+MASTERDIR= ${.CURDIR}/../libapreq2
-WITH_APACHE2= yes
-INSTALLS_SHLIB= yes
-USE_AUTOTOOLS= libtool:15
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--enable-perl-glue --with-apache2-apxs=${APXS}
-USE_PERL5= yes
-USE_APACHE= yes
-WRKSRC= ${WRKDIR}/${DISTNAME:C/_[0-9]+//}
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+WITH_MODPERL2= yes
-MAN3= APR::Request::Apache2.3 APR::Request::CGI.3 APR::Request::Cookie.3 \
- APR::Request::Error.3 APR::Request::Param.3 APR::Request.3 \
- APR::Request::Hook.3 APR::Request::Parser.3 Apache2::Cookie.3 \
- Apache2::Upload.3 Apache2::Request.3
-
-post-configure:
- cd ${CONFIGURE_WRKSRC}/glue/perl && \
- ${PERL5} Makefile.PL -apxs ${APXS} && \
- ${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
-
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"